Announcement Announcement Module
Collapse
No announcement yet.
not able to upgrade to 2.8.0 Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • not able to upgrade to 2.8.0

    i'm trying to upgrade my current STS 2.7.1 installation to 2.8.0 and it throws an error as below.


    Code:
    cannot complete the install because of a conflicting dependency.
      Software being installed: SpringSource Tool Suite 2.8.0.201110171000-RELEASE (com.springsource.sts.ide 2.8.0.201110171000-RELEASE)
      Software currently installed: Shared profile 1.0.0.1310711647973 (SharedProfile_com.springsource.sts.ide 1.0.0.1310711647973)
      Only one of the following can be installed at once: 
        SpringSource Tool Suite 2.8.0.201110171000-RELEASE (com.springsource.sts.ide 2.8.0.201110171000-RELEASE)
        SpringSource Tool Suite 2.7.1.201107091000-RELEASE (com.springsource.sts.ide 2.7.1.201107091000-RELEASE)
      Cannot satisfy dependency:
        From: Shared profile 1.0.0.1310711647973 (SharedProfile_com.springsource.sts.ide 1.0.0.1310711647973)
        To: com.springsource.sts.ide [2.7.1.201107091000-RELEASE]

    can someone tell me what is the meaning of this error..

    Thanks.

    Regards,
    Venky

  • #2
    Your STS is installed in a read-only location. You need to either move it or give the current user write privileges in order to perform the update. If you are on windows and have installed into C:\Program Files, then you must move your install. You shouldn't need to delete, just a move should work.

    Comment

    Working...
    X