Announcement Announcement Module
Collapse
No announcement yet.
why is http://dist.springsource.com/release/TOOLS/third-party/.... always broken Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • why is http://dist.springsource.com/release/TOOLS/third-party/.... always broken

    I currently have a grey cloud of obscenities hovering above my house trying to install the third party tools via the extension tab on the dashboard. I don't use a proxy, and I am pretty frustrated that I constantly get the dialogue box saying: "Communication with repository at http://dist.springsource.com/release...arty/..../e3.7 failed." Does anyone at SpringSource know about this????

  • #2
    Hey!

    The update site that you mention is up and running fine, but maybe you are facing some networking issues that make access to this site slow in your case. There is this other thread that is related and trying to fix the problem with increased timeout settings. Maybe that helps for you as well?

    http://forum.springsource.org/showth...-to-repository

    Can you also try to access this with the browser:
    http://dist.springsource.com/release...eArtifacts.xml

    Does it show up immediately?

    HTH,
    Martin

    Comment


    • #3
      Yes, it does show up immediately, but still times out in STS.

      Comment


      • #4
        I have exactly the same problem on WinXP Prof.
        When I try to use the repository link directly in the Firefox/IE I got the following response:
        <?xml version="1.0" encoding="UTF-8" ?>
        - <Error>
        <Code>AccessDenied</Code>
        <Message>Access Denied</Message>
        <RequestId>5BEB987C5A582C17</RequestId>
        <HostId>XDUUyWOYyYeS87fJFhKfNsJVkihcUbJ9dxlnWv29rg ia1Era1MFYcNvw/+eFSXRP</HostId>
        </Error>

        Comment


        • #5
          You cannot use the repository link as it is from a browser, it is just meaningful when added to STS/Eclipse as update site. Therefore the access denied message is correct if you just post the repo URL into Firefox/IE or whatever browser. You could instead try this to see if the update site is accessible:

          http://dist.springsource.com/release...eArtifacts.xml

          -Martin

          Comment


          • #6
            OK, the link:

            http://dist.springsource.com/release...eArtifacts.xml

            works fine, but it does not help me to solve the problem.

            Comment


            • #7
              Interestingly enough - soloshenko's reply seems to indicate there is an issue in Windows. I am getting the timeout on my Win7 64-bit machine using the Windows 64-bit distro. I also installed STS 2.8.0 last night on my Mac which has Mac OS X Lion and installing those extensions worked without issue.

              Comment


              • #8
                May be you are right about Windows issue, however I installed Grails (current production release) and Time Tracking extensions without any problem.

                Comment


                • #9
                  Maybe a timeout issue, maybe take a look here:
                  http://forum.springsource.org/showth...-to-repository

                  HTH,
                  Martin

                  Comment


                  • #10
                    i had the exact prob - here's how I solved it.

                    I was able to install it just at this moment at (50%) now. After 3 gruelling days. I decided to uninstall everything again and reinstalled it in another drive instead of C:\. (I tried making the C:\ attribute read only to false and modifying the read only registry but did not do it). If anyone facing the same prob, try installing STS or eclipse in another drive other than C. thanks

                    Comment

                    Working...
                    X