Announcement Announcement Module
Collapse
No announcement yet.
Springsource toolsuite hangs on startup Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Springsource toolsuite hangs on startup

    The version is 2.8.0. Ubuntu 11.10.
    Seems 2.7.2 was the same, because just updated. Yesterday all worked fine. I have moved projects in workspace to maven, seems this is the problem, other workspaces opens fine. Now green loading box just stay, IDE opens but I cant use it. It doesn't take CPU just nothing happens.
    Also on Ubuntu 11.04 it (2.7.2) was not stable at all. Always crashed 7 times in day. Seems it was SVN stored password problem, because yesterday it offered some option to disable with SVN plugin.
    Which is most stable STS version for linux?
    I found previous unremoved version I used before, it is 2.5.0.M3 - workspace opens without problems!
    Once more editing this topic - for second and next starts same problems occurred with 2.5.0 version
    Ok, now the same problem for all versions, all workspaces. WTF! Ubuntu?
    $ java -version
    java version "1.6.0_26"
    Java(TM) SE Runtime Environment (build 1.6.0_26-b03)
    Java HotSpot(TM) 64-Bit Server VM (build 20.1-b02, mixed mode)
    Last edited by emorozovs; Oct 19th, 2011, 03:26 AM. Reason: Some more info

  • #2
    Hi!

    Can you attach the crash logs for the STS crashes?
    And for the hang on startup: Can you try to capture a stack trace (using jps and jstack for example) while its hanging so that we can see what is going on?

    Thanks,
    Martin

    Comment


    • #3
      Seem I have uploaded crash log.
      About second point with hang. I have downloaded last version from springsource site and everything was just fine...
      Now tried to open workspace once more with those ide-s and just eclipse has started, it showed window with some maven legacy configuration advice, closing which eclipse continued to work... So I cant reproduce that problem, and can't imagine why it killed my half work time

      Comment


      • #4
        Glad to hear that the hangs do no longer occur. If they happen again, please use jps and jstack to capture a thread dump and send it to us.
        With regards to the crash: this seems to be the case because of some problems in GTK, see for example this: https://bugs.launchpad.net/ubuntu/+s...-6/+bug/500776

        I guess nothing we can do about this at the moment.

        HTH,
        -Martin

        Comment

        Working...
        X