Announcement Announcement Module
Collapse
No announcement yet.
STS 2.8.0 released Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • STS 2.8.0 released

    Dear Spring Community,

    I am happy to announce the newest release 2.8.0 of the SpringSource Tool Suite (STS).

    Highlights from this release:
    • ships on top of Eclipse Indigo SR1
    • includes full IDE support for Java 7 (coming with the Eclipse 3.7.1 update)
    • support for Spring 3.1 bean profiles, including validation and navigation
    • support for Spring 3.1 c-namespace including quick-fixes, validation and content-assist
    • improved constructor-arg validation and quick-fixes
    • updated Eclipse Maven integration (m2e 1.0.100), including migration assistance
    • support for Groovy 1.8.2
    • support for Grails 2.0.0.M2
    More details can be found in the New and Noteworthy document.
    As always downloads are available from the STS download page.

    Attention: if you are going to upgrade an existing 2.7.x (or previous) installation to STS 2.8.0, you need to manually upgrade the m2e components. This blog post explains the steps in detail.

    A note to dm Server tooling users: Beginning with this STS release the dm Server tooling is no longer compatible. If you wanna keep using the dm Server tooling, you should continue to use STS 2.7.x or switch to the upcoming release of the Virgo IDE from Eclipse (planned for the end of the year).

    Regards,
    Martin
    Last edited by Andrew Eisenberg; Oct 18th, 2011, 03:17 PM.

  • #2
    Originally posted by Martin Lippert View Post
    open the extension install page of the dashboard and install the m2e 1.0.100 composite upgrade
    I must be blind. Where is this exactly? I'm not seeing it. =)

    Comment


    • #3
      I tried but many of such features can't be uninstalled (button greyed).
      Any suggestion ?
      Tks
      Tullio

      Comment


      • #4
        Hi Matt!

        Originally posted by mcsenter View Post
        I must be blind. Where is this exactly? I'm not seeing it. =)
        Did you upgrade to STS 2.8.0 from an older STS 2.7.x installation? This is the only case in which the install will show up. If you already have m2e 1.0 installed because of some reason (manually, coming from STS 2.8.0.M2, etc.), this extension will not show up, because you already have m2e 1.0.

        HTH,
        Martin

        Comment


        • #5
          Originally posted by Martin Lippert View Post
          Hi Matt!



          Did you upgrade to STS 2.8.0 from an older STS 2.7.x installation? This is the only case in which the install will show up. If you already have m2e 1.0 installed because of some reason (manually, coming from STS 2.8.0.M2, etc.), this extension will not show up, because you already have m2e 1.0.

          HTH,
          Martin
          Yep. Upgraded from a 2.7.x installation. Definitely don't have m2e 1.0 installed.

          EDIT: Specifically, my previous version was 2.7.2.201109131000-RELEASE
          Last edited by mcsenter; Oct 18th, 2011, 09:20 AM.

          Comment


          • #6
            Hey Tullio!

            Originally posted by tullio0106 View Post
            I tried but many of such features can't be uninstalled (button greyed).
            Any suggestion ?
            Tks
            Tullio
            Is the button always greyed out, even if you select just one of those components, like the WTP add-on, for example?

            Comment


            • #7
              Following Your indications I was able to cancel them and installed the new one.
              Now my project are no more Maven projects (but the pom is still there) and I'm not able to enable dependencies anymore.
              Also looking for the Project --> Configure item in order to migrate such projects I've no Configure item in project menu.

              Maven plugin seems to be installed correctly.
              Tks
              Tullio

              Comment


              • #8
                Martin,

                I just scrapped the old 2.7.2 -> 2.8.0 upgrade installation and installed 2.8.0 fresh. Everything is working now.

                Comment


                • #9
                  I edited Martin's original post to point to the blog post that explains how to upgrade your version of m2e. Here is the link: http://blog.springsource.com/2011/10...l-suite-2-8-0/

                  Comment


                  • #10
                    Martin,

                    I installed STS 2.8.0 before I saw your note that: "dm Server tooling... is no longer compatible". I have uninstalled it now but am unable to find the "update site" so that I can revert to 2.7.2

                    Can you point me in the right direction?

                    Thanks.

                    Comment


                    • #11
                      Hey!

                      There are three options:
                      - You can download the older version as a package from the official STS download pages.
                      - You can download the archived update site for older STS versions from that download page as well and use it locally.
                      - You can access the old update sites directly here:
                      http://dist.springsource.com/release....RELEASE/e3.6/
                      http://dist.springsource.com/release....RELEASE/e3.7/

                      HTH,
                      Martin

                      Comment


                      • #12
                        Outdated link

                        The link to STS Installation Instructions under "Update Site Installation " on the download page is outdated, it links to the instructions for 2.5.0.M3.

                        Comment


                        • #13
                          Hi!

                          Thanks for the feedback!!! Can you tell me exactly where you found this outdated link? When I take a look at the downloads page at:
                          http://www.springsource.com/downloads/sts

                          I get this as link for the installation instructions, both at the top of the page as well as in the update site installation section:
                          http://download.springsource.com/rel...structions.pdf

                          Can you be more exact where the outdated link is?

                          Thanks!!!
                          -Martin

                          Comment


                          • #14
                            Glad to help. I'm looking at http://www.springsource.com/products/eclipse-downloads

                            Search for "Update Site Installation" (near the bottom of the page) and you'll find the outdated link.

                            Comment


                            • #15
                              I followed the blog instructions however I still have a plugin lifecycle error.
                              I tried to find the missing plugin as from instructions but I didn't find the missing plugins : org.codehaus.mojo:gwt-maven-plugin:2.2.0:resources and com.vaadin:vaadin-maven-plugin:1.0.1:update-widgetset
                              Could You suggest a solution.

                              Comment

                              Working...
                              X