Announcement Announcement Module
Collapse
No announcement yet.
STS very slow in building workspace. "Loading *-context.xml". Network activity Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Hey!

    "jps" on the command line does not work for you? Hm, that is strange... When I run "jps" on my Mac, it returns a list of process IDs, some of them with a name, some without. When I then guess the right process ID for STS and run "jstack <pid>" with that process ID, it produces the thread dumps. Are you sure there is no process ID in front of the resulting "Jps" output? And maybe one more for the STS process?

    -Martin

    Comment


    • #17
      That's right. When I was doing "jps" it just returns something like:
      20555 Jps
      I was starting STS from my doc at the bottom. Today I've started it from the command line and I am able to get at least one other line from jps, so I'll post the jstack when it happens again. (Of course, when I posted the first time, it was happening constantly - now not so much.)

      Comment


      • #18
        Hey!

        Interesting, that jps doesn't show the process ID when you are starting STS from the dock, that doesn't happen for me. But anyway, I am looking forward to your thread dumps for more details on this.

        Thanks,
        Martin

        Comment


        • #19
          I've tried to attach the jstack output, but it is 50763 bytes which exceeds the limit for attachments (or at least attachments of .txt files). What is the best way to include it here?

          Comment


          • #20
            Hey!

            Can you add it to this issue (with a short comment when you took the thread dump, etc.)
            https://issuetracker.springsource.com/browse/STS-2634

            That would be awesome!

            Thanks,
            -Martin

            Comment


            • #21
              OK, it's attached as jstack.txt.

              Comment


              • #22
                Great, thanks!!!

                Comment


                • #23
                  Obviously, a fix would be great, but I'm desperate for any kind of workaround. What could I disable to stop this from happening?

                  Comment


                  • #24
                    Hey!

                    You can remove the Spring project nature, that could be a workaround, but it is the rather aggressive version of a workaround... ;-) I am working on a fix for this. Please attach some more thread-dumps to the bug in JIRA if you come across this issue. And maybe a full sample project would also be of great help for this!!!

                    -Martin

                    Comment


                    • #25
                      Hey,

                      I just found that when I open the this *-context.xml in STS with Spring Config Editor and disable context in Namespaces tab the problem goes away... My question is how can this affect developing? I have configured VMware vFabric tc Server to have hot swap. Does this turning off the context in namespaces can cause any problems?

                      Thanks in advance.

                      Comment


                      • #26
                        Hey!

                        You mean when you disable the context namespace in the Namespaces tab of an spring-config.xml file? That means that you did't use the "context" namespace in your config xml, but you had declared it and that slowed it down?

                        -Martin

                        Comment


                        • #27
                          Hey,

                          This are my first steps with STS so after I disabled this context namespace in spring-config.xml my application didn't start up so i had to add it back I was thinking that is not editor for this file. I was thinking this is some validator setting. After searching in google for some solution I just turned off Spring builder (didn't turn off nature) and it works well for me. I've found no other satisfying solution.

                          Comment


                          • #28
                            Hey!

                            Ah, okay, good to know and thanks for the update. Is there any chance to get a sample projects that behaves so slow on your end? I really would love to see this slowdown on my end as well in order to find out what exactly causes this issue.

                            Thanks for your help!
                            -Martin

                            Comment


                            • #29
                              I've solved the issue by removing all "Config Files" in the Spring "Beans Support" in the project properties.
                              In case of Web Application, I had to disable Config Detection.(see attached image.)
                              You might need to enable it only when you are working on Spring configurations.

                              Attachment
                              Attached Files
                              Last edited by sinihong; Oct 11th, 2012, 12:26 AM.

                              Comment


                              • #30
                                Hey!

                                Can you capture a few thread dumps for us while STS slows down to dramatically when having those config files configured there? I hope that we can figure out what is going wrong with this in order to fix the root cause of this. Capturing some thread dumps is easy using jps and jstack while STS is slow. Would help us a lot!!!

                                Thanks!
                                -Martin

                                Comment

                                Working...
                                X