Announcement Announcement Module
Collapse
No announcement yet.
Spring 2.7.2 upgrade or fresh install - both having serious issues Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Spring 2.7.2 upgrade or fresh install - both having serious issues

    I installed STS 2.7.1 on Aug 1 and was running fine. Then stupid, Stupid! me, on Sept 30? 29? clicked the "updates are downloaded, ready to install box". I guess I updated to 2.7.2.

    On restart I got a Java initializing tools error and things were acting *funny* (slow, files not displaying right...). I restarted, then I couldn't see any xml files because "...no descriptor for SpringConfigEditor...".

    Tried -clean, nothing. Tried to go back to the previous version but the un-install failed. Tried one even farther back in time - another fail.

    Fine, I did a fresh install of 2.7.2 (with Java 1.6_18). For the first startup (which I never got out of for a couple days) it worked fine. But... I shut my machine down Friday and started it back up this morning. Java tool initializing error - restarted STS -now back to the problem where I can't see xml files because there is no Spring descriptor. There are lots of maven filled errors on startup.

    Before I say more... Does anyone even care about this out there in Spring land? Am I the only one with errors? Do you want to see any of the errors? which ones?

    I'm now going back to 2.7.1 and hopefully that will fix it. But possibly I've messed up my workspace - the thought of creating a new workspace makes me tremble. All those tweaks I've done... years worth... I don't even know where to begin. Is there any tool to help migrate just settings/launches from one STS to another?

  • #2
    Of course we care! Very sorry you are having such a terrible time.

    Yes, we do want to see the errors. The errors are the most vital (and possibly only) clues into trying to determine why your installation is acting up.

    First thing to do is probably take a look at the STS Error log. If you don't know which errors would be interesting or not, err on the side of caution and get us the whole thing and let someone else decide what is or is not helpful in diagnosing the problem.

    The error log can be viewed inside STS by opening the Error log viewer: "Windows >> Show View >> Other >> Error Log".
    You can export the error log from there.

    The one thing you can do to try to limit the amount of data in the log (to be more relevant to the problem) is to start by clearing the log file first. Then restart STS (so we get just the error log entries logged by the startup sequence...). Then export the contents of the error log and attach it here.

    We would probably most be interested in figuring out why there is some problem starting/initializing the Java tooling. It sounds like something is going wrong in your startup sequence and that leaves you with a lot of STS components not being properly started / initialized causing all kinds of trouble down the line.

    Comment


    • #3
      I have the log of the update (looks like 9/28). Looks like I have a lot of ui.file.save errors for the last month so that's probably no big deal.

      My STS plugins:
      PyDev
      PyDev Mylyn Integration (never use)
      viPlugin
      Oracle Enterprise Pack (WebLogic Server, DB, Coherence only)
      Findbugs
      Eclemma
      Apache Directory (LDAP browser, rarely use).

      I don't use maven though all the maven is there (someday... when I get time to learn it...)

      Tell me if you can read this file. The log from the install point to the java initializing error was already around 100KB so I had to zip it to get it in the post.


      Attachment
      Attached Files

      Comment


      • #4
        Hey!

        I've taken a look at the error log and that looks like some serious problems. The first one is that the Maven Eclipse integration doesn't seem to work and causes the Java Tooling to not finish its initialization correctly. So could try to uninstall the Maven features to see if that solves at least these problems.

        The second issue I can see is a problem with the Spring Config Editor. I don't know exactly what is going wrong there and I am not sure whether that is a result of the Java Tooling issues or not.

        Can you try to uninstall the Maven integration? Would be interesting if that works and helps!

        -Martin

        Comment


        • #5
          Thank you. I will do a series of tests over the weekend and update this thread. Btw, my version 2.7.1 is working fine so as long as I don't update I'm fine.

          Comment

          Working...
          X