Announcement Announcement Module
Collapse
No announcement yet.
Exception when editing xml Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Exception when editing xml

    Eclipse, SDK Version: 3.1.1, Build id: M20050929-0840, java.version=1.5.0_03
    ExadelStudioPro-3[1].0.5

    !ENTRY org.eclipse.ui.workbench 4 2 2005-11-20 20:10:09.375
    !MESSAGE Problems occurred when invoking code from plug-in: "org.eclipse.ui.workbench".
    !STACK 0
    java.lang.NoSuchMethodError: org.eclipse.wst.xml.ui.internal.contentoutline.JFa ceNodeAdapter.<init>(Lorg/eclipse/wst/sse/core/internal/provisional/INodeAdapterFactoryV
    at org.springframework.ide.eclipse.beans.ui.editor.ou tline.BeansJFaceNodeAdapter.<init>(BeansJFaceNodeA dapter.java:36)
    at org.springframework.ide.eclipse.beans.ui.editor.ou tline.BeansJFaceNodeAdapterFactory.createAdapter(B eansJFaceNodeAdapterFactory.java:51)
    at org.eclipse.wst.sse.core.internal.provisional.Abst ractAdapterFactory.adaptNew(AbstractAdapterFactory .java:65)
    ......

    Thanks for help
    eismeraldo

  • #2
    Hi,

    can you please post your eclipse configuration details (Help -> Eclipse SDK -> Configuration Details) as it seams to me that you have a WTP version installed - which is bundled with ExadelStudioPro - which is not compatible with Spring IDE's Xml Editor.

    Cheers

    Christian

    Comment


    • #3
      Exception when editing xml

      Thank you for your reply
      I have now an answer from Max, pleas read!

      The problem is mainly due to String IDE plug-in. Exadel Studio comes and is based on WTP plug-in version 1.0M8 while, the current version of Spring IDE is based on WTP version 0.7. WTP internal XML editor APIs changed significantly between WTP 0.7 and 1.0M8 . They are aware of this problem, see this bug: http://springide.org/project/ticket/168 .

      Try this workaround, let us know if this works.

      Open the file ExadelStudioPro-3.0.5\eclipse\plugins\org.springframework.ide.ecli pse.beans.ui.editor_0.7.0\plugin.xml

      Comment the section as shown here:
      Code:

      <import plugin="org.springframework.ide.eclipse.beans.ui" />
      </requires>
      <!-- // START COMMENT

      <extension point="org.eclipse.core.runtime.contentTypes">
      .....
      .....
      </extension>
      // END COMMENT -->
      <extension
      point="org.eclipse.wst.xml.core.catalogContributio ns">
      .........

      _________________
      Max
      Exadel-support
      ***Exadel Studio Guide:
      http://www.exadel.com/exadelstudio

      Comment


      • #4
        Hi,

        basically I can't agree with the mail you got from Exadel's support: They packaged the Spring Beans XML Editor with an unsupported WTP version what is not our fault (refer to http://springide.org/project/wiki/Be...r#Requirements). Furthermore we released our XML Editor based on an offical release version of WTP (0.7) and not of an unstable milestone (M8) release.

        Since yesterday the ticket #168 http://springide.org/project/ticket/168 is closed in our source trunk.

        There is nothing the Spring IDE team can do now. It is up to Exadel ...

        Cheers

        Christian

        Comment

        Working...
        X