Announcement Announcement Module
Collapse
No announcement yet.
Unable to install breakpoint in... Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Unable to install breakpoint in...

    Hi

    I've got an STS problem that's got me beat. Really hope someone can help. I'm writing an application that is deployed to Tomcat 7.0.12. The application can be published to the server and the server started without any problems.

    Recently, when setting a breakpoint then starting the server in debug mode, I get the message:

    Unable to install breakpoint in ... due to missing line number attributes. Reason: Absent Line number information.

    Debugging on the server used to work for me! I don't know what I changed to break this. Maybe the upgrade to 2.7.0?? My Java compiler settings are set to add line number attributes. There is no explicit build.xml file, the Tomcat server settings are the default ones. Breakpoints are set in my application code only.

    If no breakpoints are set, the server starts in debug mode without complaint, but ignores any breakpoints that are set while the server is running.

    Does anyone have any idea what's going on?

    Bruno.

  • #2
    Typically, you get the message "Absent line number information" when you code is compiled without the appropriate debug info in the class file. This is enabled by default, but perhaps it has been disabled in your class fils somehow. You should still be able to set method entry-exit breakpoints, though.

    So first, try the method entry/exit points by selecting a method in the outline view or package explorer, right ciick -> Toggle Method Breakpoint. Hopefully, that will work.

    Then, check your compilation settings. Project -> Properties -> Java Compiler -> Classfile Generation and make sure all of the checkboxes are checked.

    Comment


    • #3
      Hi Andrew

      Thanks so much for your message. This is getting weird...

      I followed your instructions. (Java compiler checkboxes were already all checked.) Setting a breakpoint on a method entry worked fine - the server started in debug mode without complaint, and the breakpoint was handled appropriately when it was encountered during execution.

      While in the Debug perspective, I added some line breakpoints. These were handled correctly too.

      I then went to the Spring perspective, and restarted the server in debug mode. The "Absent line number information" error messages were displayed.

      Just to check, I tried starting the server in debug mode, with the IDE in Debug perspective. The same error messages were displayed.

      So I doubt whether this has to do with my class files - line breakpoints were handled correctly when the IDE is in the Debug perspective and the breakpoints have been added after server startup. Otherwise not.

      Thoughts?

      Bruno.

      Comment


      • #4
        Hmm...this is starting to sound like a bug. At least you have a work around to keep you going. I'll forward this on to my colleague who is more familiar with this area (he lives in Germany and so may already be in the weekend, so he may not get back to you soon).

        Comment


        • #5
          Hey!

          This sounds indeed like a strange problem and I don't know the answer right away. But it would be interesting to find out where the problem exactly is.
          - Can you try the same thing with a new workspace and a toy project?
          - Can you try to run STS with the "-clean" option once to see if that makes a difference?

          Thanks for your help tracking this down!
          -Martin

          Comment

          Working...
          X