Announcement Announcement Module
Collapse
No announcement yet.
STS 2.7 on Debian with openJDK? Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • STS 2.7 on Debian with openJDK?

    Anyone using STS 2.7 under Debian and care to share their experiences? What JVM did you use? Caveats?

    I'm planning to try and run the PPC port of Debian on an old but nice Powerbook G4 17", which limits me to openJDK. I haven't been able to make STS run on OpenJDK 7 on the mac, but possibly there is less problems with openJDK on Debian.

    Why is it that Springsource won't fully support openJDK?
    Last edited by MiB; Dec 9th, 2011, 02:08 PM.

  • #2
    What are the problems you are having running STS with OpenJDK on the Mac? I tried this a while ago and it worked.
    If you have the latest OpenJDK builds and problems running STS, let us know the details and we can figure out what needs to be done to get STS running. Did you also try to run Eclipse on your OpenJDKs?

    -Martin

    Comment


    • #3
      Martin, I haven't tried this since STS 2.6, but I tried to point to the jdk in my STS.ini file I believe. STS couldn't instantiate the virtual machine.

      I haven't had the time to roll my own build, so I've been using the few binary builds that are available. The latest was "openjdk7-macppc-2011-01-31". I see there are later builds there now.

      The jdk seemed to work fine otherwise, but i couldn't run STS on it.

      Comment


      • #4
        The difference that I am seeing is that you are running an OpenJDK 1.7 on a PPC mac whereas I tried it on an Intel mac with the "official" OpenJDK builds (which are only for Intel as far as I know). I have no experience running that PPC version of the OpenJDK you are using, therefore no idea what might be going wrong there. Are you sure you tried the Carbon build of STS/Eclipse? As far as I remember the Cocoa builds are not running on PPC.

        HTH,
        Martin

        Comment


        • #5
          Martin, what steps did you take in order to make STS to use openJDK on your intel machine? Did you just set the -vm flag? to the path of the java command? You suggested this to me in February

          In my case that would be " -vm /usr/local/openjdk7/bin/java". Is this something you had to set in STS.ini?

          I was under the impression that it was STS 2.8 that was built for Java7? Perhaps this is mainly regarding the official Oracle version and openJDK could work anyway?

          I'm running the Cocoa version of STS Version 2.7.1.RELEASE (Build Id: 201107091000) on my Dual G5 that uses OS X 10.5.8 right now. Why would one choose a Carbon version? I think that's for older system versions.
          Last edited by MiB; Dec 9th, 2011, 01:42 PM.

          Comment


          • #6
            Hey!

            I thought setting the VM in the Info.plist should do the trick, but it seems like there is a bug preventing Eclipse from running on top of OpenJDK on Mac at the moment:
            https://bugs.eclipse.org/bugs/show_bug.cgi?id=339788
            (seems like my tests on OpenJDK are too long ago... ;-)

            STS 2.8.0.M1 contains some updates to make Spring Roo run correctly within STS when having STS running on top of Java7. So STS 2.7.1 should also run on top of an JDK 1.7.0 (as long as you don't run into that JIT bug).

            With regards to the Cocoa vs. Carbon discussion I just wasn't sure whether SWT for Cocoa is also built for PPC, but it seems like you are running Cocoa on PPC, so looks like it works... :-)

            -Martin

            Comment


            • #7
              Perhaps you already know this, but just in case, I think you have to make sure that in STS.ini you put the "-vm" and "/usr/local/openjdk7/bin/java" on two separate consecutive lines.
              The Eclipse thingy that is reading the .ini file is *very* picky about where the line breaks are. I recall having problems with that myself a while back.

              Perhaps this is not your problem... but just in case it, I though I'd mention it. If you already have the arguments on separate lines, be so kind to ignore my post and pretend I didn't post anything :-)

              Comment


              • #8
                Kris, I didn't remember this detail about different lines, so thank you. It didn't help though.

                Comment

                Working...
                X