Announcement Announcement Module
Collapse
No announcement yet.
Unable to add extensions - grails support and groovy eclipse in STS Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Unable to add extensions - grails support and groovy eclipse in STS

    Need some help,

    I am trying to add extensions as shown on the grails website - the 3 i wanted to add was grails, grails support, and groovy eclipse. It installed grails, but keeps throwing an error when trying to add grails support and groovy eclipse. see below

    Problems occurred while performing installation: Operation details
    Operation details
    Cannot complete the install because of a conflicting dependency.
    Software being installed: Groovy-Eclipse Feature 2.5.1.xx-20110628-1600-e37 (org.codehaus.groovy.eclipse.feature.feature.group 2.5.1.xx-20110628-1600-e37)
    Software currently installed: Shared profile 1.0.0.1310204049110 (SharedProfile_com.springsource.sts.ide 1.0.0.1310204049110)
    Software currently installed: SpringSource Tool Suite 2.7.1.201107091000-RELEASE (com.springsource.sts.ide 2.7.1.201107091000-RELEASE)
    Only one of the following can be installed at once:
    Java Development Tools Core 3.7.0.xx-20110628-1600-e37 (org.eclipse.jdt.core 3.7.0.xx-20110628-1600-e37)
    Java Development Tools Core 3.7.0.v_B61 (org.eclipse.jdt.core 3.7.0.v_B61)
    Cannot satisfy dependency:
    From: Shared profile 1.0.0.1310204049110 (SharedProfile_com.springsource.sts.ide 1.0.0.1310204049110)
    To: org.eclipse.jdt.core [3.7.0.v_B61]
    Cannot satisfy dependency:
    From: SpringSource Tool Suite 2.7.1.201107091000-RELEASE (com.springsource.sts.ide 2.7.1.201107091000-RELEASE)
    To: com.springsource.sts.package.feature.group [2.7.1.201107091000-RELEASE]
    Cannot satisfy dependency:
    From: SpringSource Tool Suite Package 2.7.1.201107091000-RELEASE (com.springsource.sts.package.feature.group 2.7.1.201107091000-RELEASE)
    To: org.eclipse.jdt.feature.group 0.0.0
    Cannot satisfy dependency:
    From: Groovy-Eclipse Feature 2.5.1.xx-20110628-1600-e37 (org.codehaus.groovy.eclipse.feature.feature.group 2.5.1.xx-20110628-1600-e37)
    To: org.codehaus.groovy.jdt.patch.feature.group [2.1.3.xx-20110628-1600-e37]
    Cannot satisfy dependency:
    From Patch: org.codehaus.groovy.jdt.patch.feature.group 2.1.3.xx-20110628-1600-e37 Eclipse Java Development Tools 3.7.0.v20110520-0800-7z8gFchFMTdFYKuLqBLqRja9B15B (org.eclipse.jdt.feature.group 3.7.0.v20110520-0800-7z8gFchFMTdFYKuLqBLqRja9B15B)
    To: org.eclipse.jdt.core [3.7.0.xx-20110628-1600-e37]

  • #2
    It looks like you are trying to install Groovy-Eclipse into a shared install area (ie- your install location is read-only). This is an Eclipse limitation and not something that STS or Groovy-Eclipse can easily change. Please try running the install as the root user.

    Comment


    • #3
      thanks! could you explain in a little detail how to do that.

      Comment


      • #4
        either log in as a root user, launch STS, and then install.
        Or mark the install directory as writable, launch STS and then install.

        Comment


        • #5
          wonderful, thanks

          Comment

          Working...
          X