Announcement Announcement Module
Collapse
No announcement yet.
MVC Template, broken dependancy Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • MVC Template, broken dependancy

    Hello

    STS 2.7.1, Jdk1.6_26. Maven 3.0.3.

    I have a red cross on my pom.xml:
    Missing artifact org.springframework.roo:org.springframework.roo.an notations:jar:1.0.2.RELEASE: provided

    I tried changing it to 1.1.5 (I figured it might be the latest roo version instead), but it didnt work either.

    Spent way too long trying to fix this, so I'm hoping someone has some answers.
    The MVC template seems extremely buggy.

    [EDIT]
    It also says this:
    Failure to transfer org.springframework.roo:org.springframework.roo.an notations:jar:1.0.2.RELEASE from http://maven.springframework.org/milestone was cached in the local repository, resolution will not be reattempted until the update interval of org.springframework.maven.milestone has elapsed or updates are forced. Original error: Could not transfer artifact org.springframework.roo:org.springframework.roo.an notations:jar:1.0.2.RELEASE from/to org.springframework.maven.milestone (http://maven.springframework.org/milestone): For input string: "HTTP/1.1" pom.xml /HelloWorld_MVC line 1 Maven Problem

    Maybe its a server problem?
    Last edited by Gr3y; Jul 23rd, 2011, 07:11 PM.

  • #2
    I fixed it (maybe).

    I deleted the .m2 folder.
    Maven3 redownloaded everything.
    However it still complained that a non-existing path was referenced.
    The path existed, however.

    I made THAT problem go away by going to prefs>maven>user setting and then pressing the "Update Settings" button.

    All the wierdo errors went away (for some reason).

    Sigh...

    Using windows 7 ultimate x64 btw.

    Comment

    Working...
    X