Announcement Announcement Module
Collapse
No announcement yet.
STS 2.7.1 - Hibernate Tools 3.4.0 install error Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • STS 2.7.1 - Hibernate Tools 3.4.0 install error

    I am trying to install Hibernate tools in SpringSource Tool Suite. I am using the jBoss update site (http://download.jboss.org/jbosstools/updates/stable/) and I get a bunch of dependency errors (See below).

    I am reasonably new to this, so not sure what to do here. Should I be installing from a different update site?

    Any assistance would be appreciated. Thanks


    Cannot complete the install because of a conflicting dependency.
    Software being installed: Hibernate Tools 3.4.0.v20110215-1252-H31-GA (org.hibernate.eclipse.feature.feature.group 3.4.0.v20110215-1252-H31-GA)
    Software currently installed: SpringSource Tool Suite 2.7.1.201107091000-RELEASE (com.springsource.sts.ide 2.7.1.201107091000-RELEASE)
    Only one of the following can be installed at once:
    Structured Source Editor 1.2.4.v201103231819 (org.eclipse.wst.sse.ui 1.2.4.v201103231819)
    Structured Source Editor 1.3.0.v201105101529 (org.eclipse.wst.sse.ui 1.3.0.v201105101529)
    Structured Source Editor 1.2.3.v201102102045 (org.eclipse.wst.sse.ui 1.2.3.v201102102045)
    Only one of the following can be installed at once:
    Structured Source XML Model 1.1.504.v201104070043 (org.eclipse.wst.xml.core 1.1.504.v201104070043)
    Structured Source XML Model 1.1.503.v201102102045 (org.eclipse.wst.xml.core 1.1.503.v201102102045)
    Structured Source XML Model 1.1.600.v201104251227 (org.eclipse.wst.xml.core 1.1.600.v201104251227)
    Cannot satisfy dependency:
    From: SpringSource Tool Suite 2.7.1.201107091000-RELEASE (com.springsource.sts.ide 2.7.1.201107091000-RELEASE)
    To: com.springsource.sts.package.feature.group [2.7.1.201107091000-RELEASE]
    Cannot satisfy dependency:
    From: SpringSource Tool Suite Package 2.7.1.201107091000-RELEASE (com.springsource.sts.package.feature.group 2.7.1.201107091000-RELEASE)
    To: org.eclipse.jpt.common.eclipselink.feature.feature .group 0.0.0
    Cannot satisfy dependency:
    From: SpringSource Tool Suite Package 2.7.1.201107091000-RELEASE (com.springsource.sts.package.feature.group 2.7.1.201107091000-RELEASE)
    To: org.eclipse.wst.xml_ui.feature.feature.group 0.0.0
    Cannot satisfy dependency:
    From: Dali Java Persistence Tools - Common EclipseLink Core 1.0.0.v201105180000 (org.eclipse.jpt.common.eclipselink.core 1.0.0.v201105180000)
    To: bundle org.eclipse.wst.xml.core [1.1.600,2.0.0)
    Cannot satisfy dependency:
    From: Dali Java Persistence Tools - EclipseLink Common 1.0.0.v201104050000-3--8s73553C4G3333 (org.eclipse.jpt.common.eclipselink.feature.featur e.group 1.0.0.v201104050000-3--8s73553C4G3333)
    To: org.eclipse.jpt.common.eclipselink.core [1.0.0.v201105180000]
    Cannot satisfy dependency:
    From: Dali Java Persistence Tools - UI 2.3.2.v201008252310 (org.eclipse.jpt.ui 2.3.2.v201008252310)
    To: bundle org.eclipse.wst.sse.ui [1.1.0,1.3.0)
    Cannot satisfy dependency:
    From: WST XML Core 3.2.3.v201102160550-7C7OFXcF7RZHQKIkMxMsW_ (org.eclipse.wst.xml_core.feature.feature.group 3.2.3.v201102160550-7C7OFXcF7RZHQKIkMxMsW_)
    To: org.eclipse.wst.xml.core [1.1.503.v201102102045]
    Cannot satisfy dependency:
    From: WST XML Core 3.2.4.v201103231834-7C7OFXfF7RZHQLInN2MhWd (org.eclipse.wst.xml_core.feature.feature.group 3.2.4.v201103231834-7C7OFXfF7RZHQLInN2MhWd)
    To: org.eclipse.wst.xml.core [1.1.504.v201104070043]
    Cannot satisfy dependency:
    From: Eclipse XML Editors and Tools 3.2.3.v201102160550-7H7AFUWDxumQJOi9ghcTb5YgkwEZ (org.eclipse.wst.xml_ui.feature.feature.group 3.2.3.v201102160550-7H7AFUWDxumQJOi9ghcTb5YgkwEZ)
    To: org.eclipse.wst.xml_core.feature.feature.group [3.2.3.v201102160550-7C7OFXcF7RZHQKIkMxMsW_]
    Cannot satisfy dependency:
    From: Eclipse XML Editors and Tools 3.2.4.v201103170600-7H7AFUaDxumQJOs8hggQZ6_jl1EOJGNlUsOsTM (org.eclipse.wst.xml_ui.feature.feature.group 3.2.4.v201103170600-7H7AFUaDxumQJOs8hggQZ6_jl1EOJGNlUsOsTM)
    To: org.eclipse.wst.xml_core.feature.feature.group [3.2.4.v201103231834-7C7OFXfF7RZHQLInN2MhWd]
    Cannot satisfy dependency:
    From: Eclipse XML Editors and Tools 3.3.0.v201103310011-7H7EFZ-DxumTla66ahfUnHfpsz0u5Z92pU4TxSL (org.eclipse.wst.xml_ui.feature.feature.group 3.3.0.v201103310011-7H7EFZ-DxumTla66ahfUnHfpsz0u5Z92pU4TxSL)
    To: org.eclipse.wst.sse.ui [1.3.0.v201105101529]
    Cannot satisfy dependency:
    From: Hibernate Tools 3.4.0.v20110215-1252-H31-GA (org.hibernate.eclipse.feature.feature.group 3.4.0.v20110215-1252-H31-GA)
    To: org.jboss.tools.hibernate.jpt.ui [3.4.0.v20110215-1252-H31-GA]
    Cannot satisfy dependency:
    From: Hibernate Jdt UI 3.4.0.v20110215-1252-H31-GA (org.jboss.tools.hibernate.jpt.ui 3.4.0.v20110215-1252-H31-GA)
    To: bundle org.eclipse.jpt.ui 0.0.0

  • #2
    Hi!

    The message looks like the Hibernate Tools are depending on a bundle org.eclipse.jpt.ui, which is no longer part of the standard Eclipse JEE Indigo distribution. Therefore the install process seems to try to install those older jpa bundles - and that produces a version conflict among the org.eclipse.wst bundles. Did you try to install the Hibernate tools into a standard Eclipse Indigo JEE package? Did that work? That would be a way to check if the Hibernate tools are compatible with Eclipse Indigo.

    I think there are two ways to solve this problem: You could create a Eclipse Helios based STS installation (install Eclipse JEE Helios package and install STS via the update sites into that) and then install the Hibernate tools into that or you could try to check whether there is a newer version of the hibernate tools that are compatible with Eclipse JEE Indigo (3.7).

    HTH,
    Martin

    Comment

    Working...
    X