Announcement Announcement Module
Collapse
No announcement yet.
Unable to connect to cloudfoundry Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Unable to connect to cloudfoundry

    Hi

    While creating a new server when I specify SSL url - https://api.cloudfoundry.com, STS is unable to connect to the server.

    It works fine over a non ssl url.

    Regards
    Vishnu

  • #2
    Hi Vishnu,

    As far as I know only http://api.cloudfoundry.com is available. Is there a reason you can't connect to that URL?

    Terry

    Comment


    • #3
      Hi Terry

      I am able to connect to http://api.cloudfoundry.com, but its not a secured url.

      Using vmc command line, I can login using

      vmc target https://api.cloudfoundry.com (https instead of http) and then do a vmc login


      In STS I am unable to create a new cloudfoundry server if I use https://api.cloudfoundry.com

      Regards
      Vishnu

      Comment


      • #4
        Hi Vishnu,

        You are right. Vmc does allow for targeting to https://api.cloudfoundry.com. Thanks for reporting this and I have created the following JIRA issue to track this issue:

        STS-1956: Unable to connect to https://api.cloudfoundry.com
        https://issuetracker.springsource.com/browse/STS-1956

        Terry

        Comment


        • #5
          Hi Vishnu,

          During this time before we have a proper fix in the Cloud Foundry integration to work with secure URLs, you can try adding the certificate into the jre keystore as a workaround. You can follow the instructions in this blog post: http://letmehelpyougeeks.blogspot.co...-to-javas.html.

          Cheers,
          Terry

          Comment


          • #6
            Hi Vishnu,

            The certificate for https://api.cloudfoundry.com has been changed to work with default JRE setting, so now creating a server with the secure URL should work as expected. In the next Cloud Foundry milestone release the default Cloud Foundry URL will be set to use the secure URL.

            Cheers,
            Terry

            Comment


            • #7
              Hi Terry

              Thanks for the update, will check it out

              Regards
              Vishnu

              Comment

              Working...
              X