Announcement Announcement Module
Collapse
No announcement yet.
Server startup exception Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Server startup exception

    With no apps loaded (vfabric tc server v2.5), I get the following error on startup (via STS) any ideas what the cause might be?

    Strictly the first server startup (with a deployed application) after a laptop reboot is ok. Subsequent server restarts fail, even if the application is removed.


    Exception in thread "purgeThread" org.springframework.dao.DataIntegrityViolationExce ption: could not delete: [com.springsource.insight.repo.resource.persist.Per sistedApplicationResource#1261]; SQL [delete from resources where id=? and version=?]; constraint ["FK_RESOURCES_APPLICATION: PUBLIC.RESOURCES FOREIGN KEY(APPLICATION) REFERENCES PUBLIC.RESOURCES(ID)"; SQL statement:
    delete from resources where id=? and version=? [23003-147]]; nested exception is org.hibernate.exception.ConstraintViolationExcepti on: could not delete:
    ...

    Detail in ex.txt

    Any pointers would be appreciated. Thanks

  • #2
    Solved:

    I deleted all server instances, re-created a new server instance but this time I selected only the base template. Previously not really understanding what the templates were, I had selected all of them; there isnt an explanation of what you are meant to do when presented with the template list or what the obvious defaults might be. Anyway with only base, I had no problems.

    n.b. Recreating the server instance with all templates selected brought the problem back.

    Comment


    • #3
      I had the same problem, but with the default server on a fresh STS 2.7.1 install.
      I removed it and recreated per your instructions and it seemed to work, so thanks.

      Comment


      • #4
        I'm seeing the same stack trace on my server launch. I thought it had to do with my web app so removed them and restored server.xml to have only original content (I think) but I'm getting the same stack trace you're getting. I would like to see the explanation when someone responds. I'm running within STS-2.7.1.

        Comment


        • #5
          I had not created new instances from within STS before. That worked as well for me using just the base but I would imagine that you would want at least base + insight. I tried that and it worked fine as well. When you add insight it comes up with the message saying that insight is available for this instance so that you can select yes and then you have that available.

          Comment


          • #6
            I did not have to create a new instance. Just deleting the data directory under spring-insight-instance>insight seems to do the trick.

            Comment

            Working...
            X