Announcement Announcement Module
Collapse
No announcement yet.
I am angry -STS error Groovy:unable to resolve class E Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • I am angry -STS error Groovy:unable to resolve class E

    Hi, I occasionally obtain unreasonable errors for groovy source:

    * Groovy:unable to resolve class E
    * The type Object is not generic; it cannot be parameterized with arguments <E>


    They mostly occur in pair and for sources that has no real errors ,even in new groovy source file.

    When this starts to happen, it propagates to many groovy files

    Any idea?
    We are usingSpringSource Tool Suite Version: 2.7.1.RELEASE. and Ubuntu 10.04,Grails 1.3.7

    In other forum I saw the next answer:
    "This was fixed in the last few days, please upgrade to a recent groovy-eclipse dev build using the update site: http://dist.codehaus.org/groovy/dist...snapshot/e3.6/"

    But dosnt work,this is the link (http://forum.springsource.org/showth...e-class-E-quot)

    Before all this, I try to install STS with the new version of groovy , and also have a problems:

    http://forum.springsource.org/showth...-2.7.0.RELEASE

    What happen with the STS for Linux? There any way that can I use STS+Grails+Ubuntu, without problems?.

    Thanks for any help,you are mi last hope jeje

  • #2
    This sounds a lot like a bug in Greclipse that was recently fixed. You can try upgrading Greclipse to a more recent version. For example from the one of the dev update sites

    Links to update sites here:
    http://groovy.codehaus.org/Eclipse+P...ingOtherBuilds

    Comment


    • #3
      Actually we appear to be tracking a new manifestation of this issue, you might want to track: https://issuetracker.springsource.com/browse/STS-1953

      cheers
      Andy

      Comment

      Working...
      X