Announcement Announcement Module
Collapse
No announcement yet.
SpringSource Tool Suite 2.7.0.M2 and Vaadin Plug-in... Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • SpringSource Tool Suite 2.7.0.M2 and Vaadin Plug-in...

    I recently tried to upgrade using STS 2.7.0.M2, Roo 1.1.4 and using the Vaadin plug-in. I realize there are issues with the Roo 1.1.4 release so I configured STS to use 1.1.3. All seemed fine at first. I then installed the Vaadin plug-in. The problem is that when I click "File > New > Other" I don't see "Vaadin" listed as an option so I don't seem to be able to access the plug-in functionality. Is this a problem with the 2.7.0.M2 release or is this related to the GWT install/integration errors with 2.7.0.M2?

  • #2
    Hey!

    I've tried the Vaadin Eclipse plugin with the STS 2.7.0 release and it seems to work fine. I can install it and see several items in the Vaadin category when I select "File -> New -> Other". Also the installation of the Google plugins work nicely. So I cannot reproduce the issues you are talking about (Google plugin, Vaadin plugin) here, either with the 2.7.0 release nor with the 2.7.0.M2 build, all the installs work fine. Did you try to install all this into a fresh STS to see if that works within your environment?

    HTH,
    Martin

    Comment


    • #3
      Martin, thanks for the update. I did have a few STS installs (2.6.0 and two 2.7) with Roo 1.1.3 and 1.1.4. I was trying to see what combinations of each would work as I am still having issues with Roo 1.1.4 (patiently waiting on 1.2 !) A new install seems to have got things back to working...

      Comment


      • #4
        Glad to hear that you got it back working... Hope that the upcoming Roo versions fix your problems with Roo.

        Cheers,
        -Martin

        Comment

        Working...
        X