Announcement Announcement Module
Collapse
No announcement yet.
m2eclipse version in sts 2.7.0.RELEASE Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • m2eclipse version in sts 2.7.0.RELEASE

    Hi,
    Just downloaded the 2.7.0.RELEASE from your download pages
    Indigo comes with m2e 1.0.0 and you still bundle m2e 0.10,0,11 and 0.12 in some strange mix (could just be me reading the dependencies incorrectly).
    So I would like to know the reason behind this "downgrade" and what would happen if I uninstalled your m2e and installed the new one.
    Rumour has it that m2e is really moving forward so I like being on the latest version.

    Thanks!

  • #2
    Hey!

    We are somewhat conservative with updating this dependency, since the new m2eclipse version ships with Indigo and a totally new namespace (everything being renamed to match the Eclipse naming conventions). Therefore we are going to wait until the m2eclipse-addons have adopted this new m2eclipse version before we will ship that with STS by default.

    Best regards,
    -Martin

    Comment


    • #3
      maven

      why Maven 2.2.1??

      Comment


      • #4
        I opened an issue in JIRA to update Maven and m2eclipse:
        https://issuetracker.springsource.com/browse/STS-1919

        Comment


        • #5
          Cam we please get maven 3.0 support Please and thanks... btw STS is awesome

          Comment


          • #6
            You can change the Maven installation via Preferences > Maven > Installations and choose the directory where Maven 3.0.3 is installed.

            Comment


            • #7
              I ask you to resolve mentioned issue ASAP.
              Bugs in pre-1.0 m2e versions (such as validating target folder files and producing many of meaningful warnings and errors) are very painful.

              Comment

              Working...
              X