Announcement Announcement Module
Collapse
No announcement yet.
Failing to install Grails Support extension Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Failing to install Grails Support extension

    This happens when trying to install the "Grails Support" under Language and Framework Tooling section. I have successfully installed Grails (current production release) under Languages and Frameworks as well as Groovy Eclipse.

    Please advise. Thanks in advance.

    Session Data:
    Code:
    eclipse.buildId=M20110210-1200
    java.version=1.6.0_25
    java.vendor=Sun Microsystems Inc.
    BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_US
    Framework arguments:  -product org.eclipse.epp.package.jee.product
    Command-line arguments:  -os win32 -ws win32 -arch x86 -product org.eclipse.epp.package.jee.product
    Stack Trace:
    Code:
    Problems occurred while performing installation: Operation details
    Operation details
    Cannot complete the install because one or more required items could not be found.
    Software being installed: SpringSource Tool Suite Grails Support 2.6.0.201105041000-RELEASE (com.springsource.sts.grails.feature.group 2.6.0.201105041000-RELEASE)
    Missing requirement: SpringSource Tool Suite Grails Support (Core) 2.6.0.201103161000-RELEASE (com.springsource.sts.grails.core 2.6.0.201103161000-RELEASE) requires 'bundle org.apache.commons.io 0.0.0' but it could not be found
    Missing requirement: SpringSource Tool Suite Grails Support (Core) 2.6.0.201105041000-RELEASE (com.springsource.sts.grails.core 2.6.0.201105041000-RELEASE) requires 'bundle org.apache.commons.io 0.0.0' but it could not be found
    Cannot satisfy dependency:
    From: SpringSource Tool Suite Grails Editor Support (Core) 2.6.0.201105041000-RELEASE (com.springsource.sts.grails.editor.groovy 2.6.0.201105041000-RELEASE)
    To: bundle com.springsource.sts.grails.core 0.0.0
    Cannot satisfy dependency:
    From: SpringSource Tool Suite Grails Support 2.6.0.201105041000-RELEASE (com.springsource.sts.grails.feature.group 2.6.0.201105041000-RELEASE)
    To: com.springsource.sts.grails.editor.groovy [2.6.0.201105041000-RELEASE]

  • #2
    Normally the missing bundle "org.apache.commons.io" comes as part of STS. What are you installing this on top of?

    I found a relevant older posting that seems to be about your problem:
    http://forum.springsource.org/archiv.../t-106568.html

    Seems there are two possible solutions:
    - install STS from the official distribution zip or installer package
    - add another update site to get the missing bundle: http://download.eclipse.org/tools/or...754/repository

    I can't really provide more specific help, because don't know what you are trying to install the Grails support extension into exactly.

    Please have a read through the older post and see if it helps you at all.

    Also if you are not installing on top of an STS installed from an official distribution from here:
    http://www.springsource.com/products/eclipse-downloads

    Then please try with an official STS distribution package.

    Comment


    • #3
      Thanks!

      Thank you for your help. The linked thread is similar to my problem. However, after upgrading to STS 2.7.0, the issue was resolved.

      Comment


      • #4
        Glad to hear it :-)

        Comment

        Working...
        X