Announcement Announcement Module
Collapse
No announcement yet.
STS can't connect to cloudfoundry Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • STS can't connect to cloudfoundry

    At 12 Jun, I apply for an account from cloudfoundry.com and received it. when I use the account withe STS 2.6.1SR1 or 2.7.0M2 to connect cloudfoundry.com, generate an error: "Failed to connect to server:Operation not permitted (403 Forbidden)", but "Account information is valid". Why?

  • #2
    Hi!

    So I guess you can validate your credentials in the wizard correctly, but any subsequent actions fail with an 403?

    After adding the server, can you see the password field being filled with some dots when you open the server editor? If not, STS failed to store your credentials in the secure storage. If you are on a Mac, I would deactivate the Mac OSX keysotre integration in the secure storage settings (Preferences -> General -> Security -> Secure Storage). After that you can type in your password in the server editor again, press save, and go. I don't know exactly why the OSX keystore integration has those problems, but you can solve them this way.

    But that doesn't help, I would check the credentials using the vmc command line tool for Cloud Foundry, just to check if that works.

    HTH,
    Martin

    Comment


    • #3
      Hi, Martin,
      thank you for the effort.
      My computer's OS is win7 wth sp1, and win7 have the same problems, after I deactivate the "Windows Integration", the STS can connect the cloudfoundry and work.
      Thank you very much.

      Comment


      • #4
        I"m not able to connect to Cloud Foundry from STS 2.7. I have a mac OS 10.x. I created the Cloud Foundry Server successfully and validated my account successfully within the wizard but get the 403 forbidden error. I made sure the password was in the server properties as you suggested but still no luck. I'm working from home so no proxy server is in the way. Suggestions?

        Comment


        • #5
          Hey!

          So you were able to validate your credentials from within the wizard and the password shows up as dots when you open the servers editor? Are you able to validate it again from the servers editor as well?

          -Martin

          Comment


          • #6
            I have to re-enter in the password since it seems that isn't saved in the STS tool. So I'm in the server's editor window when I try validating. The validation works fine.

            Comment


            • #7
              It seems that STS is not able to store your credentials. Can you disable the native integration for the secure storage from your preferences? I had the same problems as long as the Mac OSX keystore integration was enabled.

              HTH,
              Martin

              Comment


              • #8
                After unchecking the secure storage option and rebooting my mac and sts I now see that I can connect to Cloud Foundry . Thank you so much for your help!

                Comment


                • #9
                  Glad to hear that it is working now!

                  Cheers,
                  -Martin

                  Comment

                  Working...
                  X