Announcement Announcement Module
No announcement yet.
Eclipse shuts down in about 1 min, the stacktrace seems to point to a STS issue Page Title Module
Move Remove Collapse
Conversation Detail Module
  • Filter
  • Time
  • Show
Clear All
new posts

  • Eclipse shuts down in about 1 min, the stacktrace seems to point to a STS issue

    I'm getting the following error, when Eclipse STS simply shuts down:

    !ENTRY org.springframework.ide.eclipse.beans.core.metadat a 4 2 2011-06-09 00:16:04.089
    !MESSAGE Problems occurred when invoking code from plug-in: "org.springframework.ide.eclipse.beans.core.metada ta".
    !STACK 0
    at .getLineNumber(
    at vaModelSourceLocation.<init>(JavaModelSourceLocati
    at com.springsource.sts.ide.metadata.core.AutowireAnn otationMetadataProvider.provideBeanMetadata(Autowi
    at org.springframework.ide.eclipse.beans.core.metadat a.internal.model.DelegatingAnnotationReadingMetada taProvider$
    at .java:42)
    at org.springframework.ide.eclipse.beans.core.metadat a.internal.model.DelegatingAnnotationReadingMetada taProvider.processFoundAnnotations(DelegatingAnnot
    at org.springframework.ide.eclipse.beans.core.metadat a.model.AbstractAnnotationReadingMetadataProvider. provideBeanMetadata(AbstractAnnotationReadingMetad
    at org.springframework.ide.eclipse.beans.core.metadat a.internal.model.BeanMetadataBuilderJob$
    at .java:42)
    at org.springframework.ide.eclipse.beans.core.metadat a.internal.model.BeanMetadataBuilderJob.attachMeta dataToBean(
    at org.springframework.ide.eclipse.beans.core.metadat a.internal.model.BeanMetadataBuilderJob.attachMeta data(
    at org.springframework.ide.eclipse.beans.core.metadat
    at ava:54)

    My environment is:
    java.vendor=Sun Microsystems Inc.
    BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=en_US
    Framework arguments: -product com.springsource.sts.ide
    Command-line arguments: -os win32 -ws win32 -arch x86_64 -product com.springsource.sts.ide

    Any idea why this would be? I tried using another workspace, and another, fresh installation of Eclipse STS, without solving the problem.
    Any help is appreciated.

  • #2

    I created a JIRA issue for the NPE:

    Nevertheless I am not sure whether that is related to the slow shutdown or not. Can you capture a thread dump while this long-running shutdown and attach it here? That would be great!
    (Run jps to get a list of all java processes running on your system. And then jstack on the specific process to print the stack.)



    • #3
      Sorry I wasn't clear enough with the wording - it's not slowly shutting down. It's running for about a minute and then immediately shuts down. I have been trying to capture a dump with different vm parameters but didn't spend to much time on it. I also assumed that when this kind of error occurs Eclipse does log the stack somewhere and indeed it is logged in the .metadata dir of the workspace. The stack I provided is from that log. Thanks for the help and the JIRA.


      • #4

        Thanks for providing the stack trace for the exception. Would be great if you could capture a thread dump (as described) while its running for this minute (right before the shutdown), just to see what exactly might cause the IDE to hang for such a long time.