Announcement Announcement Module
Collapse
No announcement yet.
Latest Grails Support & dm Server Tools STS extensions not compatible Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Latest Grails Support & dm Server Tools STS extensions not compatible

    STS extensions "Grails Support 2.6.0.201105041000-RELEASE" and "dm Server Tools 2.7.0.201105101000-M1" are not compatible.

    On a plain STS installation (Version: 2.6.1.RELEASE, Build Id: 201105041000) when I try to install latest extension of "Grails Support" and "dm Server Tools" I receive following error:

    Code:
    Problems occurred while performing installation: Operation details
    Operation details
    Cannot complete the install because of a conflicting dependency.
    Software being installed: SpringSource Tool Suite Grails Support 2.6.0.201105041000-RELEASE (com.springsource.sts.grails.feature.group 2.6.0.201105041000-RELEASE)
    Software being installed: SpringSource Tool Suite dm Server Tools 2.7.0.201105101000-M1 (com.springsource.sts.server.dm.feature.group 2.7.0.201105101000-M1)
    Only one of the following can be installed at once: 
    SpringSource Tool Suite Best Practices 2.6.0.201103161000-RELEASE (com.springsource.sts.bestpractices 2.6.0.201103161000-RELEASE)
    SpringSource Tool Suite Best Practices 2.7.0.201105101000-M1 (com.springsource.sts.bestpractices 2.7.0.201105101000-M1)
    SpringSource Tool Suite Best Practices 2.6.0.201105041000-RELEASE (com.springsource.sts.bestpractices 2.6.0.201105041000-RELEASE)
    Cannot satisfy dependency:
    From: SpringSource Tool Suite (required) 2.6.0.201103161000-RELEASE (com.springsource.sts.feature.group 2.6.0.201103161000-RELEASE)
    To: com.springsource.sts.bestpractices [2.6.0.201103161000-RELEASE]
    Cannot satisfy dependency:
    From: SpringSource Tool Suite (required) 2.6.1.201105041000-RELEASE (com.springsource.sts.feature.group 2.6.1.201105041000-RELEASE)
    To: com.springsource.sts.bestpractices [2.6.0.201105041000-RELEASE]
    Cannot satisfy dependency:
    From: SpringSource Tool Suite (required) 2.7.0.201105101000-M1 (com.springsource.sts.feature.group 2.7.0.201105101000-M1)
    To: com.springsource.sts.bestpractices [2.7.0.201105101000-M1]
    Cannot satisfy dependency:
    From: SpringSource Tool Suite Grails Support 2.6.0.201105041000-RELEASE (com.springsource.sts.grails.feature.group 2.6.0.201105041000-RELEASE)
    To: com.springsource.sts.feature.group [2.6.0,2.7.0)
    Cannot satisfy dependency:
    From: SpringSource Tool Suite dm Server Tools 2.7.0.201105101000-M1 (com.springsource.sts.server.dm.feature.group 2.7.0.201105101000-M1)
    To: com.springsource.sts.feature.group 2.7.0

  • #2
    Upgrading to STS Version: 2.7.0.M1 Build Id: 201105101000 helped.

    Comment


    • #3
      Hey!

      I also found the reason for this problem: The extension listing for 2.6.x pointed to the wrong version of the dm server tools. This should work now again for 2.6.x versions as well as 2.7.0 builds of STS.

      Cheers,
      -Martin

      Comment


      • #4
        I am still seeing this issue. Just downloaded springsource-tool-suite-2.6.1.SR1-e3.6.2-win32-x86_64 last night.

        New to STS and Grails. Am I doing something wrong?

        Version information and error details below:


        SpringSource Tool Suite
        Version: 2.6.1.RELEASE
        Build Id: 201105041000


        Problems occurred while performing installation: Operation details
        Operation details
        Cannot complete the install because of a conflicting dependency.
        Software being installed: SpringSource Tool Suite Grails Support 2.6.0.201105041000-RELEASE (com.springsource.sts.grails.feature.group 2.6.0.201105041000-RELEASE)
        Software currently installed: Shared profile 1.0.0.1305714850327 (SharedProfile_com.springsource.sts.ide 1.0.0.1305714850327)
        Software currently installed: Maven Integration for WTP (Optional) 0.11.1.20101108-1810 (org.maven.ide.eclipse.wtp.feature.feature.group 0.11.1.20101108-1810)
        Only one of the following can be installed at once:
        Java Development Tools Core 3.6.2.xx-20110426-1500-e36 (org.eclipse.jdt.core 3.6.2.xx-20110426-1500-e36)
        Java Development Tools Core 3.6.2.v_A76_R36x (org.eclipse.jdt.core 3.6.2.v_A76_R36x)
        Cannot satisfy dependency:
        From: Shared profile 1.0.0.1305714850327 (SharedProfile_com.springsource.sts.ide 1.0.0.1305714850327)
        To: org.eclipse.jdt.core [3.6.2.v_A76_R36x]
        Cannot satisfy dependency:
        From: SpringSource Tool Suite Grails Support 2.6.0.201105041000-RELEASE (com.springsource.sts.grails.feature.group 2.6.0.201105041000-RELEASE)
        To: org.codehaus.groovy.eclipse.feature.feature.group 2.0.0
        Cannot satisfy dependency:
        From: Groovy-Eclipse Feature 2.1.3.xx-20110426-1500-e36 (org.codehaus.groovy.eclipse.feature.feature.group 2.1.3.xx-20110426-1500-e36)
        To: org.codehaus.groovy.jdt.patch.feature.group [2.1.3.xx-20110426-1500-e36]
        Cannot satisfy dependency:
        From: Maven Integration for WTP (Optional) 0.11.1.20101108-1810 (org.maven.ide.eclipse.wtp.feature.feature.group 0.11.1.20101108-1810)
        To: org.eclipse.jdt.feature.group 3.2.0
        Cannot satisfy dependency:
        From Patch: org.codehaus.groovy.jdt.patch.feature.group 2.1.3.xx-20110426-1500-e36 Eclipse Java Development Tools 3.6.2.r362_v20101117-0800-7z8XFW6FLFlmjJcvz03jyeFBLS_F (org.eclipse.jdt.feature.group 3.6.2.r362_v20101117-0800-7z8XFW6FLFlmjJcvz03jyeFBLS_F)
        To: org.eclipse.jdt.core [3.6.2.xx-20110426-1500-e36]

        Comment


        • #5
          Problem solved. Was able to successfully install SpringSource Tool Suite Grails Support on STS 2.6.1.RELEASE. Made two changes. Not sure which one was the relevant change:

          1. Removed my GRAILS_HOME environment variable so STS would not see my existing Grails installation
          2. Installed STS to a non-admin protected directory. (Originally installed under c:\Program Files on Win7. New installation folder under c:\Users\MyUser)

          Comment


          • #6
            Glad to hear that you have solved this. I am not 100% sure what caused the problem, but I would guess something around your second point...
            Anyway, thanks for sharing your solution to this!!!

            Cheers,
            -Martin

            Comment

            Working...
            X