Announcement Announcement Module
Collapse
No announcement yet.
Spring Source Tool Suite Hangs on "Creating Roo project: starting Spring Roo Shell" Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Spring Source Tool Suite Hangs on "Creating Roo project: starting Spring Roo Shell"

    I trying create a new Roo Project in Spring Source Tool Suite. The dialogue shows a progress bar with a message stating "Creating Roo project: starting Spring Roo Shell.

    The only thing I can do is go to task manager and kill the windows process associated with the Spring Source Tool Suite.

    At this point nothing happens. I can start a spring roo project from the command line.

    OS: Windows 7
    STS: 2.6.2.SR1

    Anyone experience similar problems?

    Thanks,

    Randall

  • #2
    hi Randall!

    Can you capture a thread dump while STS hangs during this?
    (Run jps to get a list of all java processes running on your system. And then jstack on the specific process to print the stack.)
    That would be great and we could see in more detail what exactly is going wrong.

    Thanks!
    -Martin

    Comment


    • #3
      I had the same problem while creating a Spring ROO project off Eclipse. Attached is the eclipse dump.

      Comment


      • #4
        Tried creating a ROO project from the command prompt and them importing it into eclipse. Tried starting the roo shell for the new project and it hangs up again.

        Comment


        • #5
          The attached thread dump look good as far as I can see, no real reason why STS hangs here. Does this happen every time you try to open a Roo shell or create a Roo project from within STS?

          Comment


          • #6
            Maybe you are observing the same problem as described here:
            http://forum.springsource.org/showth...r-showing-null

            Comment


            • #7
              The Roo Shell works fine from the command prompt... Hangs only when I use it to create a new project through Eclipse using the STS IDE plugins.

              Comment


              • #8
                Did you look at the other thread I mentioned?

                Comment


                • #9
                  Ok, I'll give that a try. I updated to Eclipse Indigo a few days back on my laptop and it has been running fine off it. Let me try if the solution works for me. I'll update this thread with my findings.

                  Thanks!

                  Comment

                  Working...
                  X