Announcement Announcement Module
No announcement yet.
POM editor - unable to add dependencies as search always returns 0 results. Page Title Module
Move Remove Collapse
Conversation Detail Module
  • Filter
  • Time
  • Show
Clear All
new posts

  • POM editor - unable to add dependencies as search always returns 0 results.

    Within POM editor, when I add dependencies e.g. junit (or any else) the search results is always empty. How might I resolve the problem?

    The problem arises after creating a new workspace. The same STS 2.6.1 (I was using 2.5.x & had the same problems with it) opened against all other existing workspaces works perfectly, so the STS deployment is good. I can create new projects with the Archetype, which are pre loaded with dependancies - I just can not add additional dependencies.

    Iíve checked the maven workspace properties they look identical. I'm at a loss to understand what might be missing, or how to go about debugging the problem. Any help would gratefully appreciated


  • #2
    always the way - find a solution AFTER asking the question.

    Window > Preferences > Maven > Download repository index updates on startup.

    ticking this and restarting STS, resolved the problem. I've never had to tick this within other workspaces to get them to work - this is what through me - but its working now.



    • #3
      Glad you found a solution and thanks for sharing your solution with us!!! :-)


      • #4
        sry for reactivating this thread, but i have the exactly same problem. no matter what i'm searching for, the search always returns 0 (i'm trying to add spring-jdbc to the dependencies). as already mentioned i ticked the option in the preferences window, restarted sts and let it fetch the index, but still no results.

        any ideas?


        • #5

          I tried this again and using the solution that is mentioned above worked for me (switching the option on, restarting STS, waiting until the Maven index got updated which takes a while, and then opening the pom.xml editor to add a dependency).

          When you enable the mentioned option in the Maven preferences, do you see anything in the progress view after a restart? If not, can you take a look at the Error Log view to see if there is error being reported? I could imagine a firewall/proxy problem with Maven, that happens quite often...