Announcement Announcement Module
Collapse
No announcement yet.
Can't install dm Server plugins Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Can't install dm Server plugins

    I really want the Virgo 1.0 run-time support, but it seems I have to do this by installing the dm Server plugin. I was able to do this on STS 2.6.0 on 64-bit CentOS 5.5, but I'm not able to do install it into STS 2.6.0 on 64-bit Windows 7.
    1. From the Dashboard, click Extensions.
    2. Select SpringSource dm Server Integration and click Install.
    3. SpringSource Tool Suite dm Server Tools 2.6.0.201103151000-RC3 comes up. Click Finish.

    That gives me the following error:

    Code:
    An error occurred while collecting items to be installed
    session context was:(profile=com.springsource.sts.ide, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).
    No repository found containing: osgi.bundle,com.springsource.server.ide,2.6.0.201103161000-RELEASE
    No repository found containing: osgi.bundle,com.springsource.server.ide.bundlor.core,2.6.0.201103161000-RELEASE
    No repository found containing: osgi.bundle,com.springsource.server.ide.bundlor.jdt.core,2.6.0.201103161000-RELEASE
    No repository found containing: osgi.bundle,com.springsource.server.ide.bundlor.ui,2.6.0.201103161000-RELEASE
    No repository found containing: osgi.bundle,com.springsource.server.ide.eclipse,2.6.0.201103161000-RELEASE
    No repository found containing: osgi.bundle,com.springsource.server.ide.export,2.6.0.201103161000-RELEASE
    No repository found containing: osgi.bundle,com.springsource.server.ide.facet.core,2.6.0.201103161000-RELEASE
    No repository found containing: org.eclipse.update.feature,com.springsource.server.ide.feature,2.6.0.201103161000-RELEASE
    No repository found containing: osgi.bundle,com.springsource.server.ide.jdt.core,2.6.0.201103161000-RELEASE
    No repository found containing: osgi.bundle,com.springsource.server.ide.jdt.ui,2.6.0.201103161000-RELEASE
    No repository found containing: osgi.bundle,com.springsource.server.ide.manifest.core,2.6.0.201103161000-RELEASE
    No repository found containing: osgi.bundle,com.springsource.server.ide.par,2.6.0.201103161000-RELEASE
    No repository found containing: osgi.bundle,com.springsource.server.ide.par.edit,2.6.0.201103161000-RELEASE
    No repository found containing: osgi.bundle,com.springsource.server.ide.runtime.core,2.6.0.201103161000-RELEASE
    No repository found containing: osgi.bundle,com.springsource.server.ide.runtime.ui,2.6.0.201103161000-RELEASE
    No repository found containing: osgi.bundle,com.springsource.server.ide.ui,2.6.0.201103161000-RELEASE
    No repository found containing: osgi.bundle,org.eclipse.hyades.execution,4.5.1.v201101211900
    No repository found containing: osgi.bundle,org.eclipse.hyades.probekit,4.3.2.v201101271120
    No repository found containing: osgi.bundle,org.eclipse.hyades.probekit.ui,4.1.600.v201005221043
    No repository found containing: osgi.bundle,org.eclipse.hyades.trace.ui,4.5.102.v201101211900
    No repository found containing: osgi.bundle,org.eclipse.hyades.ui,4.3.0.v201005181900
    No repository found containing: osgi.bundle,org.eclipse.tptp.platform.agentcontroller,4.3.3.v201102041430
    No repository found containing: osgi.bundle,org.eclipse.tptp.platform.common,4.4.3.v201101060044
    No repository found containing: osgi.bundle,org.eclipse.tptp.platform.common.ui,4.4.301.v201012081900
    No repository found containing: osgi.bundle,org.eclipse.tptp.platform.common.ui.trace,4.4.2.v201101211050
    No repository found containing: osgi.bundle,org.eclipse.tptp.platform.execution,4.5.1.v201101211050
    No repository found containing: osgi.bundle,org.eclipse.tptp.platform.iac.administrator,4.5.0.v201005061600
    No repository found containing: osgi.bundle,org.eclipse.tptp.platform.integration.pde,4.5.2.v201101211050
    No repository found containing: osgi.bundle,org.eclipse.tptp.platform.jvmti.client,4.5.2.v201101211050
    No repository found containing: osgi.bundle,org.eclipse.tptp.platform.logging.events,4.4.1.v201009092123
    No repository found containing: osgi.bundle,org.eclipse.tptp.platform.models,4.6.102.v201101211050
    No repository found containing: osgi.bundle,org.eclipse.tptp.platform.models.hierarchy,4.7.2.v201101211050
    No repository found containing: osgi.bundle,org.eclipse.tptp.platform.probekit.launch,4.5.0.v201005061600
    No repository found containing: osgi.bundle,org.eclipse.tptp.platform.profile.server.core,4.3.2.v201010131657
    I've also tried through the regular plugin installation method:
    1. Click Help->Install New Software...
    2. Work with SpringSource Update Site for Eclipse 3.6 - http://dist.springsource.com/release/TOOLS/update/e3.6.
    3. Type dm Server in the filter box, then select SpringSource Tool Suite dm Server Tools 2.6.0.201103161000-RELEASE (note the newer version from the Extensions version) and SpringSource dm Server Tools (required).
    4. Click Next, then Finish.

    The resulting error is almost the same, but the second one adds a few lines:

    Code:
    No repository found containing: org.eclipse.update.feature,com.springsource.sts.server.dm,2.6.0.201103161000-RELEASE
    No repository found containing: osgi.bundle,com.springsource.sts.server.quickfix,2.6.0.201103161000-RELEASE
    No repository found containing: osgi.bundle,com.springsource.sts.server.vmware.core,2.6.0.201103161000-RELEASE
    No repository found containing: osgi.bundle,com.springsource.sts.server.vmware.ui,2.6.0.201103161000-RELEASE
    I installed the dm Server plugins into my STS on CentOS yesterday, so maybe something's changed in the meantime? Or there's something different between the two, but I don't really know where to look for that sort of thing. Any help getting this fixed and/or otherwise getting Virgo support into my Windows STS would be greatly appreciated!

  • #2
    Hey Rick!

    We haven't changed anything around that time, so you should be able to install dm server support into your windows-based STS install the same way. Did you achieve this in the meantime or do you still have that problem?

    -Martin

    Comment


    • #3
      Hello all,

      I have the same installation problem: fresh win7 64bit, fresh sts, wann install the SpringSource dm Server Integration extension, got:
      Code:
      Problems occurred while performing installation: Operation details
      Operation details
      Cannot complete the install because of a conflicting dependency.
      Software being installed: SpringSource Tool Suite dm Server Tools 2.7.0.201105101000-M1 (com.springsource.sts.server.dm.feature.group 2.7.0.201105101000-M1)
      Software currently installed: Shared profile 1.0.0.1307342820801 (SharedProfile_com.springsource.sts.ide 1.0.0.1307342820801)
      Only one of the following can be installed at once: 
      SpringSource Tool Suite Template Project Wizard 2.7.0.201105101000-M1 (com.springsource.sts.wizard 2.7.0.201105101000-M1)
      Wizard Plug-in 2.6.0.201105041000-RELEASE (com.springsource.sts.wizard 2.6.0.201105041000-RELEASE)
      Cannot satisfy dependency:
      From: Shared profile 1.0.0.1307342820801 (SharedProfile_com.springsource.sts.ide 1.0.0.1307342820801)
      To: com.springsource.sts.wizard [2.6.0.201105041000-RELEASE]
      Cannot satisfy dependency:
      From: SpringSource Tool Suite (required) 2.7.0.201105101000-M1 (com.springsource.sts.feature.group 2.7.0.201105101000-M1)
      To: com.springsource.sts.wizard [2.7.0.201105101000-M1]
      Cannot satisfy dependency:
      From: SpringSource Tool Suite dm Server Tools 2.7.0.201105101000-M1 (com.springsource.sts.server.dm.feature.group 2.7.0.201105101000-M1)
      To: com.springsource.sts.feature.group 2.7.0
      need a hint.

      thx ahead
      nulli

      Comment


      • #4
        Hi!

        The extension install for STS 2.6.x pointed to the wrong version of the dm server tooling (the milestone version which is right now at 2.7.0.M1 instead of the release version). This is now fixed. Please try again by closing and re-opening the dashboard and try to install the dm server tooling again. This should work now.

        (Another option is to use the latest milestone build of STS (2.7.0.M1 at the moment) and install the dm server tooling into that version. That works as well.)

        Cheers,
        -Martin

        Comment


        • #5
          it works
          thx a lot!

          Comment


          • #6
            Hi!

            Are you running STS 2.7.0.M1 or 2.6.1? Seems like you are trying to install the dm server tooling 2.7.0.M1 into an 2.6.1 (or 2.6.0) installation, which doesn't work. How exactly did you try to install this?

            -Martin

            Comment

            Working...
            X