Announcement Announcement Module
Collapse
No announcement yet.
Installing SpringIDE in Eclipse 3.6 fails Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Installing SpringIDE in Eclipse 3.6 fails

    Hello,

    I am trying to install the SpringIDE features into an Eclipse 3.6 installation. All works fine but there is an exception if I for the Spring-enabled projects:

    Error occured processing XML 'Provider org.apache.xerces.parsers.XML11Configuration could not be instantiated: org.apache.xerces.impl.dv.DVFactoryException: DTD factory class org.apache.xerces.impl.dv.dtd.DTDDVFactoryImpl does not extend from DTDDVFactory.'. See Error Log for more details

    The full stacktrace is:
    org.apache.xerces.parsers.ObjectFactory$Configurat ionError: Provider org.apache.xerces.parsers.XML11Configuration could not be instantiated: org.apache.xerces.impl.dv.DVFactoryException: DTD factory class org.apache.xerces.impl.dv.dtd.DTDDVFactoryImpl does not extend from DTDDVFactory.
    at org.apache.xerces.parsers.ObjectFactory.newInstanc e(Unknown Source)
    at org.apache.xerces.parsers.ObjectFactory.findJarSer viceProvider(Unknown Source)
    at org.apache.xerces.parsers.ObjectFactory.createObje ct(Unknown Source)
    at org.apache.xerces.parsers.ObjectFactory.createObje ct(Unknown Source)
    at org.apache.xerces.parsers.DOMParser.<init>(Unknown Source)
    at org.apache.xerces.parsers.DOMParser.<init>(Unknown Source)
    at org.springframework.ide.eclipse.core.io.xml.LineNu mberPreservingDOMParser.<init>(LineNumberPreservin gDOMParser.java:40)
    at org.springframework.ide.eclipse.core.io.xml.Xerces DocumentLoader.loadDocument(XercesDocumentLoader.j ava:35)
    at org.springframework.beans.factory.xml.XmlBeanDefin itionReader.doLoadBeanDefinitions(XmlBeanDefinitio nReader.java:388)
    at org.springframework.beans.factory.xml.XmlBeanDefin itionReader.loadBeanDefinitions(XmlBeanDefinitionR eader.java:334)
    at org.springframework.ide.eclipse.beans.core.interna l.model.BeansConfig$2.loadBeanDefinitions(BeansCon fig.java:375)
    at org.springframework.beans.factory.xml.XmlBeanDefin itionReader.loadBeanDefinitions(XmlBeanDefinitionR eader.java:302)
    at org.springframework.ide.eclipse.beans.core.interna l.model.BeansConfig$3.call(BeansConfig.java:421)
    at org.springframework.ide.eclipse.beans.core.interna l.model.BeansConfig$3.call(BeansConfig.java:1)
    at java.util.concurrent.FutureTask$Sync.innerRun(Futu reTask.java:303)
    at java.util.concurrent.FutureTask.run(FutureTask.jav a:138)
    at java.util.concurrent.Executors$RunnableAdapter.cal l(Executors.java:441)
    at java.util.concurrent.FutureTask$Sync.innerRun(Futu reTask.java:303)
    at java.util.concurrent.FutureTask.run(FutureTask.jav a:138)
    at java.util.concurrent.ThreadPoolExecutor$Worker.run Task(ThreadPoolExecutor.java:886)
    at java.util.concurrent.ThreadPoolExecutor$Worker.run (ThreadPoolExecutor.java:908)
    at java.lang.Thread.run(Thread.java:680)


    What I am missing? The Apache Xerces feature I have installed already...

    Thorsten

  • #2
    Hey Torsten!

    I think you are hitting this one:
    https://issuetracker.springsource.com/browse/STS-1672

    So there is a patch you can install from here:
    http://dist.springsource.com/release/TOOLS/patches/e3.6

    HTH,
    Martin

    Comment


    • #3
      Hey Martin,

      Originally posted by Martin Lippert View Post
      Hey Torsten!
      So there is a patch you can install from here:
      http://dist.springsource.com/release/TOOLS/patches/e3.6
      now I get Software being installed: Eclipse for Agile BackOffice (Profile) 2.0.0.0000000009 (com.poweredbypulse.profile-1052193-rmb-1853917 2.0.0.0000000009)
      Missing requirement: Spring IDE Core Patch (STS-1672, STS-1691) 2.6.0.201104111100-PATCH (org.springframework.ide.eclipse.patch.feature.fea ture.group 2.6.0.201104111100-PATCH) requires 'org.springframework.ide.eclipse.beans.core [2.6.0.201104111100-PATCH]' but it could not be found

      if I want to install the patches...

      Thorsten

      Comment


      • #4
        Hey Thorsten!

        Sorry for not coming back to you earlier. The error report from installing the patch sounds crazy (why does the updater complains about this?). Do you still have this problem or did you find another solution?

        Cheers,
        -Martin

        Comment

        Working...
        X