Announcement Announcement Module
Collapse
No announcement yet.
Quick start: metadata information link returns a 404 Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Quick start: metadata information link returns a 404

    I am not sure what I am doing wrong, however I am stepping through the quick start guide included with the SAML extension. It tells me to replace the metadata bean and the metadataGeneratorFilter bean and then deploy the war. When I go the url specified I get a page with a couple of login providers and the metadata information link.

    The instructions state that I should click on the metadata link and click on the first provider. I get a 404 when I try to do this. In the debug log I see this:

    - No default metadata configured, generating with default values, please pre-configure metadata for production use
    - Generated default entity base URL http://localhost:8080 based on values in the first server request. Please set property entityBaseURL on MetadataGenerator bean to fixate the value.
    - Created default metadata for system with entityID: <my unique id>

    I am not sure how to proceed at this point....

  • #2
    What application server / container are you deploying on? Can you upload your war somewhere, so I can try reproducing it with your settings?

    Comment


    • #3
      I am using Tomcat 8.05, the war is here : https://dl.dropboxusercontent.com/u/...ml2-sample.war

      Thanks for taking the time to look at this. :-)

      Comment


      • #4
        I am using Tomcat 8.05, the war is here : https://dl.dropboxusercontent.com/u/...ml2-sample.war

        Thanks for taking the time to look at this. :-)

        Comment

        Working...
        X