Announcement Announcement Module
Collapse
No announcement yet.
Is spring security 3.1.x a hard dependency for 1.0.0-RC2 and later? Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Is spring security 3.1.x a hard dependency for 1.0.0-RC2 and later?

    Is spring security 3.1.x a hard dependency, or will spring security 3.0.8 or later suffice for the SAML extension?

    I'm obviously trying to determine if I need to upgrade our app's spring security dependency in order to use the extension.

    Thanks,
    Skip Walker

  • #2
    Hi Skip,

    You can still use 3.0.8, but you'd need to make few changes to the default securityContext.xml in the current trunk:

    - change schema location of Spring Security to the 3.0 version
    - change request-matcher to path-type in the security:filter
    - move unsecured pages to the security:http element

    For detail see changes to file securityContext.xml in this commit.

    Vladimir Schäfer

    Comment

    Working...
    X