Announcement Announcement Module
No announcement yet.
maven repository broken? Page Title Module
Move Remove Collapse
Conversation Detail Module
  • Filter
  • Time
  • Show
Clear All
new posts

  • maven repository broken?

    Hello, there,

    Just downloaded sparklr2 adn tonr2. Tried to build it and I got

    org.apache.maven.reactor.MavenExecutionException: Cannot find parent: for project: null:tonr2:war:null for project null:tonr2:war:null
    Caused by: org.apache.maven.project.ProjectBuildingException: POM '' not found in repository: Unable to download the artifact from any repository

    can someone please give some hints? thanks a lot

  • #2
    I just tried it out and it's working for me. This is the pom:

    Maybe you have some custom maven settings or something?


    • #3
      Hi, Thank you so much for the reply. I'm not very exp. with maven. Tried to install the parent using your pom file as

      mvn install:install-file -DpomFile=spring-security-oauth-parent-1.0.0.M3.pom

      and I got

      Unable to find resource '' in repository ....

      That is when I tried to build tonr/sparklr downloaded from

      If I tried to build them downloaded from

      I got
      Unable to find resource 'org.apache.maven.plugins:maven-idea-pluginom:2.3-atlassian-1' in repository ...

      can you please give me some hint? So desparate. Thx a million


      • #4
        The problems seem to be happening with your Maven installation. For some reason it's not seeing your repositories. There could be a variety of reasons (proxy configuration, settings.xml) but it's not really a problem with the sparklr, tonr applications.


        • #5
          I'm also having the same issue:

          [INFO] Unable to find resource '' in repository org.springframework.maven.milestone (

          Trying to browse i get similar issues


          • #6
            Hi, I finally built after downloading apache's maven. The maven I used before is a customized version (exciting to find that out), then I built the whole tuto. set downloaded from