Announcement Announcement Module
Collapse
No announcement yet.
Milestone 3 Released Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Milestone 3 Released

    OAuth for Spring Security 1.0.0.M3 was released last week (sorry for the last posting). This release brings the library up to date with draft 13 of the OAuth 2 spec and provides fixes for a variety of other issues.

    It should be noted that this will probably be the last release that supports Spring Security 3.0, depending on when 3.1 is released. Unfortunately, 3.1 introduced some non-backwards-compatible changes.

  • #2
    nullpointexception when mvn install milestone 3

    Hello, there,

    I tried to install
    spring-security-oauth-1.0.0.M3
    into my local repository as it is the <parent> dependency for sparklr and tonr2.

    Downloaded the jar and pom file from
    https://s3browse.springsource.com/br...auth/1.0.0.M3/

    but when I build it using
    mvn install -Dfile=spring-security-oauth-1.0.0.M3.jar -DpomFile=spring-security-oauth-1.0.0.M3.pom

    I got
    [INFO] Trace
    java.lang.NullPointerException
    at org.apache.maven.artifact.versioning.DefaultArtifa ctVersion.parseVersion(DefaultArtifactVersion.java :136)
    at org.apache.maven.artifact.versioning.DefaultArtifa ctVersion.<init>(DefaultArtifactVersion.java:47)
    at org.apache.maven.artifact.versioning.VersionRange. createFromVersion(VersionRange.java:219)
    at org.apache.maven.project.artifact.ProjectArtifactF actory.create(ProjectArtifactFactory.java:37)
    at org.apache.maven.project.DefaultMavenProjectBuilde r.processProjectLogic(DefaultMavenProjectBuilder.j ava:1017)
    at org.apache.maven.project.DefaultMavenProjectBuilde r.buildInternal(DefaultMavenProjectBuilder.java:88 0)
    at org.apache.maven.project.DefaultMavenProjectBuilde r.buildFromSourceFileInternal(DefaultMavenProjectB uilder.java:508)
    at org.apache.maven.project.DefaultMavenProjectBuilde r.build(DefaultMavenProjectBuilder.java:200)
    at org.apache.maven.DefaultMaven.getProject(DefaultMa ven.java:604)
    at org.apache.maven.DefaultMaven.collectProjects(Defa ultMaven.java:487)
    at org.apache.maven.DefaultMaven.getProjects(DefaultM aven.java:391)
    at org.apache.maven.DefaultMaven.doExecute(DefaultMav en.java:272)
    at org.apache.maven.DefaultMaven.execute(DefaultMaven .java:138)
    at org.apache.maven.cli.MavenCli.main(MavenCli.java:3 62)
    at org.apache.maven.cli.compat.CompatibleMain.main(Co mpatibleMain.java:60)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Nativ e Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Native MethodAccessorImpl.java:39)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(De legatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:597)
    at org.codehaus.classworlds.Launcher.launchEnhanced(L auncher.java:315)
    at org.codehaus.classworlds.Launcher.launch(Launcher. java:255)
    at org.codehaus.classworlds.Launcher.mainWithExitCode (Launcher.java:430)
    at org.codehaus.classworlds.Launcher.main(Launcher.ja va:375)
    [INFO] ------------------------------------------------------------------------
    [INFO] Total time: < 1 second
    [Loaded java.util.TimeZone$DisplayNames from /shared/jdk1.6.0_22/jre/lib/rt.jar]
    [Loaded sun.util.TimeZoneNameUtility from /shared/jdk1.6.0_22/jre/lib/rt.jar]
    [Loaded sun.util.resources.TimeZoneNamesBundle from /shared/jdk1.6.0_22/jre/lib/rt.jar]
    [Loaded sun.util.resources.TimeZoneNames from /shared/jdk1.6.0_22/jre/lib/rt.jar]
    [Loaded sun.util.resources.TimeZoneNames_en from /shared/jdk1.6.0_22/jre/lib/rt.jar]
    [Loaded java.util.spi.TimeZoneNameProvider from /shared/jdk1.6.0_22/jre/lib/rt.jar]
    [INFO] Finished at: Mon Mar 28 11:39:21 EDT 2011


    can someone plz tell me how to fix it? thanks a million

    Comment


    • #3
      Hello.

      Is there a reason that you're attempting to install the parent pom in your local repository? You should just be able to download the sample applications and build them with Maven, which should automatically pull the parent pom without you having to install it.

      Is this not working for you?

      Comment


      • #4
        Hi, stoicflame,

        Thanks a million for replying. You are right. I should be able to do that, given I am able to access the repository where the parent is stored. And I just found out that it is not the case. I did not know at the beginning,. Was trying to get around it by installing the parent locally. Then I ran into some other things cuz it has its own dependencies. It is really a headache. My colleague tried it with another env and it works.

        Sorry for all the hassle I've brought. Hope this thing may get solved soon

        Comment

        Working...
        X