Announcement Announcement Module
Collapse
No announcement yet.
Unresolved parent POM error with Tonr project Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • jporche
    started a topic Unresolved parent POM error with Tonr project

    Unresolved parent POM error with Tonr project

    Hello,

    I have tried to get both the Tonr1 and Tonr2 projects running locally. I download the source and try to run mvn install, mvn jetty:run, or pretty much anything, but I get the following error:

    Code:
    Project build error: Non-resolvable parent POM org.springframework.security.oauth:spring-security-oauth-parent:1.0.0.M1 for org.springframework.security.oauth:tonr2:1.0.0.M1: Failed to resolve POM for org.springframework.security.oauth:spring-security-oauth-parent:1.0.0.M1 due to Missing:
    ----------
    1) org.springframework.security.oauth:spring-security-oauth-parent:pom:1.0.0.M1
    ----------
    1 required artifact is missing.
    
    for artifact: 
      org.springframework.security.oauth:spring-security-oauth-parent:pom:1.0.0.M1
    
    from the specified remote repositories:
      central (http://repo1.maven.org/maven2, releases=true, snapshots=false)

  • Deejay
    replied
    I'm getting this error too, which is most irritating.

    Here's the repository infor from the Sparklr POM:
    Code:
      <repositories>
        <repository>
          <id>spring-milestone</id>
          <name>Spring Framework Milestone Repository</name>
          <url>http://s3.amazonaws.com/maven.springframework.org/milestone</url>
        </repository>
        <repository>
          <id>spring-release</id>
          <name>Spring Framework Release Repository</name>
          <url>http://maven.springframework.org/release</url>
        </repository>
      </repositories>
    Hitting http://s3.amazonaws.com/maven.spring....org/milestone directly yields
    Code:
    <Error>
    <Code>NoSuchKey</Code>
    <Message>The specified key does not exist.</Message>
    <Key>milestone</Key>
    <RequestId>3DA7DBA6E0C93AA2</RequestId>
    −
    <HostId>
    we8yRMMS07RhpYTmri+Nbnh7hijqiHa95ccu6kU3qpGeeHfhcAFw1DIeTM/Dz4Rw
    </HostId>
    </Error>
    My Nexus instance can't make sense of the Spring milestone repo either. Looks to me likes it's offline.

    Leave a comment:


  • brucegodden
    replied
    Sparklr and Tonr not building

    I was getting errors like

    Code:
    [INFO] Scanning for projects...
    Downloading: http://repo1.maven.org/maven2/org/sp...t-1.0.0.M1.pom
    [INFO] Unable to find resource 'org.springframework.security.oauth:spring-security-oauth-parent:pom:1.0.0.M1' in repository central (http://repo1.maven.org/maven2)
    when building Sparklr and Tonr. I found that inserting

    Code:
      <repositories>
        <repository>
          <id>spring-milestone</id>
          <name>Spring Portfolio Milestone Repository</name>
          <url>http://s3.amazonaws.com/maven.springframework.org/milestone</url>
        </repository>
      </repositories>
    near the start of the pom.xml files fixed the problems for me.

    Leave a comment:


  • raziel
    replied
    Hi. I'm still having the reported issue trying to deploy the sample applications.

    I tries the work around but I cannot get it to work (probably my fault on that). How should I modify the pom to get it to work?

    Thanks

    EDIT: My bad: I had an extra modification to the pom. I basically got it to work by adding the dependency and repository specified in http://forum.springsource.org/showthread.php?t=97987 to the pom.xml of the applications.
    Last edited by raziel; Dec 13th, 2010, 07:03 PM.

    Leave a comment:


  • Jeremy_Mason
    replied
    I've just had a similar problem building sparklr2 but fixed it by pasting repository and dependency extracted into pom.xml:
    http://forum.springsource.org/showthread.php?t=97987

    Leave a comment:


  • stoicflame
    replied
    Yes, there's a missing repository. The current version needs to point to the spring milestone repository.

    I'm going to make a fix shortly.

    Leave a comment:


  • jporche
    replied
    I was able to get around this issue by removing the <parent> element from the pom.xml. But now I can't seem to resolve, spring-oauth dependency no matter what version I try:
    Code:
    <dependency>
          <groupId>org.springframework.security.oauth</groupId>
          <artifactId>spring-security-oauth</artifactId>
          <version>1.0.0.M1</version>
        </dependency>
    Gives the following:

    Code:
    Missing artifact org.springframework.security.oauth:spring-security-oauth:jar:1.0.0.M1:compile
    The spring-oauth page does not list the current release, nor does mvnrepository.com even contain this group/artifact. It does list the codehouse artifacts, but there is no documention on which version I should use with Spring 3.0.5

    Leave a comment:

Working...
X