Announcement Announcement Module
Collapse
No announcement yet.
Spring OAuth2 Sample Programs generate a "UserRedirectRequiredException" Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Spring OAuth2 Sample Programs generate a "UserRedirectRequiredException"

    When I select the "View My Sparklr Photos" menu selection on the Tonr2 application, I receive a "UserRedirectRequiredException" error on the Sparklr2 application. This is occurring whether or not I have previously logged into the Sparklr2 application. Since this just started happening, is there a recent change that is causing this problem? The Tonr2 and Sparklr2 application were running without any errors or issues a couple of weeks ago.

  • #2
    Works for me (on master). Do you have steps to reproduce?

    Comment


    • #3
      I can repeat the error by running Tonr2 and Sparklr2 on servers (Tonr2 -- localhost:8585 Sparklr2 -- localhost:9595) then performing a login on Tonr2 followed by selecting the "view sparklr2 photos" menu selection on tonr2. I have a console log of the activity, but it is too big to include in as part of my response.

      Comment


      • #4
        A stack trace would help. Or you can attach log files (or put them in a gist). The apps are setup to run on the same port out of the box, so maybe you could try that as well (there are instructions in the samples README I think).

        Comment


        • #5
          Server DEBUG, TRACE, and Console Log

          Dave,

          I've attached a copy of the Console log that was produced when the failure occurred. I have previously successfully run the OAuth2 Tonr2 and Sparklr2 sample programs using 2 servers and have a Wire Shark capture file I can send if that will help.

          Comment


          • #6
            That looks pretty normal to me from the log files. The tonr client says it is redirecting at the end to http://localhost:9595/sparklr2/oauth/authorize. Is there something wrong with that? Does that URL not respond as expected? Is it the server you are running?

            Comment


            • #7
              I retested using the same server and port assignment (i.e. localhost:8585) and the example runs fine. At this point, I'm not sure why the example code was failing.

              Comment

              Working...
              X