Announcement Announcement Module
Collapse
No announcement yet.
Cannot build after bootstrap: net.oauth:oauth-core:jar:20090531 not found Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Cannot build after bootstrap: net.oauth:oauth-core:jar:20090531 not found

    I can build successfully the first time using "mvn install -P bootstrap", however if I try a "mvn install" right after that I get

    Code:
    [ERROR] Failed to execute goal on project spring-security-oauth: Could not resolve dependencies for project org.springframework.security.oauth:spring-security-oauth:jar:1.0.5.RELEASE: 
    Failure to find net.oauth:oauth-core:jar:20090531 in http://repo.maven.apache.org/maven2 was cached in the local repository, resolution will not be reattempted until the update interval of central has elapsed or updates are forced -> [Help 1]
    Very strange because the file does exist on my system.
    Code:
     % l ~/.m2/repository/net/oauth/oauth-core/20090531/     
    total 28K
    -rw-rw-r-- 1 collin collin  218 Jun  6 22:02 _maven.repositories
    -rw-rw-r-- 1 collin collin 1.6K Jun  6 22:02 oauth-core-20090531.jar
    -rw-rw-r-- 1 collin collin  703 Jun 25 09:11 oauth-core-20090531.jar.lastUpdated
    -rw-rw-r-- 1 collin collin   40 Jun  6 22:02 oauth-core-20090531.jar.sha1
    -rw-rw-r-- 1 collin collin 1.6K Jun  6 22:02 oauth-core-20090531.pom
    -rw-rw-r-- 1 collin collin  703 Jun 25 09:11 oauth-core-20090531.pom.lastUpdated
    -rw-rw-r-- 1 collin collin   40 Jun  6 22:02 oauth-core-20090531.pom.sha1
    Any idea why this strange behaviour? The oauth.googlecode.net repository is only enabled with the bootstrap profile, why is this?

  • #2
    The bootstrap profile enables us to use optional and test dependencies that are not in maven central, without polluting the build of all users of the library. If you are building locally, you can activate the bootstrap profile in your local settings.xml. Having said that I have no idea why it is not building with a locally cached jar (maybe there's a problem with the download - bad checksum or something)?

    Comment


    • #3
      worked after adding bootstrap and google repository:
      <profiles>
      <profile>
      <id>bootstrap</id>
      <repositories>
      <repository>
      <id>parent</id>
      <name>Maven repository -- bootstrap</name>
      <url>https://oauth.googlecode.com/svn/code/maven</url>
      </repository>
      </repositories>
      </profile>
      </profiles>

      Comment

      Working...
      X