Announcement Announcement Module
Collapse
No announcement yet.
Support for OAUTH in older versions of Spring Security Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Support for OAUTH in older versions of Spring Security

    I'm trying to find out whether older versions of Spring Security (specifically 2.0.4) support OAuth and if so what version of the Spring OAuth lib I'd need.

    Whilst I appreciate that I should be using the latest versions of spring, spring security, oauth etc I need to understand whether it's possible to get Spring OAuth working with the version of spring security I'm currently on.

    I've had a good google but can't find this info anywhere - if someone could give me a link to what versions support work that would be great.

  • #2
    We build and compile with Spring 3.1.2 (latest at the moment) and don't make any effort to test against any other versions, but that doesn't mean it won't work. However, I really don't think you'll have any luck with the server-side stuff and Spring < 3.1, but some other features might work with 3.0. I'm not sure if 2.0 is still supported even commercially (OAuth or not), but you could try your luck with SpringSource if you really need it.

    Comment

    Working...
    X