Announcement Announcement Module
Collapse
No announcement yet.
Spring OAuth XSD Validation in Eclipse Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Spring OAuth XSD Validation in Eclipse

    I am currently using STS as a plugin inside of eclipse. I notice that it will locate and use an XSD on the classpath. When writing my spring config and trying to set up the Authorization Code grant type I found a problem.
    Code:
    	
    <oauth:authorization-server
    		token-services-ref="authorizationServerTokenService"
    		client-details-service-ref="clientDetailsService">
    		<oauth:authorization-code
    			authorization-code-services-ref="authorizationCodeServices" />
    </oauth:authorization-server>
    This code works for me in eclipse, but it fails for my coworkers not using STS and our nightly ant build. This is because the XSD in the jar file for version 1.0.0.M6 in the milestones repo has the correct definition of the "authorization-code" element, while the reference to it via the header of the XML at http://www.springframework.org/schem...oauth2-1.0.xsd has the M5 version.

    Anything I can do, or should I just sit tight and wait for the XSD that spring exposes to be updated?

  • #2
    I've uploaded the latest XSD to the Spring website (it's not automated in the release process so I always forget). It's a little bit different from M6, but I think it's compatible.

    Comment

    Working...
    X