Announcement Announcement Module
Collapse
No announcement yet.
Unable to build latest master with maven 3 Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Unable to build latest master with maven 3

    Hey guys,
    I've tried to build with no joy several times now from the latest master branch. I'm using maven 3.0.3. Here is the output from my build.

    Code:
    
    ~/development/spring-security-oauth/spring-security-oauth2$ mvn install -P bootstrap
    [INFO] Scanning for projects...
    [WARNING] 
    [WARNING] Some problems were encountered while building the effective model for org.springframework.security.oauth:spring-security-oauth2:jar:1.0.0.BUILD-SNAPSHOT
    [WARNING] 'build.plugins.plugin.version' for org.apache.maven.plugins:maven-eclipse-plugin is missing. @ org.springframework.security.oauth:spring-security-oauth-parent:1.0.0.BUILD-SNAPSHOT, /home/toddnine/development/spring-security-oauth/pom.xml, line 153, column 21
    [WARNING] 'reporting.plugins.plugin.version' for org.codehaus.mojo:jdepend-maven-plugin is missing. @ org.springframework.security.oauth:spring-security-oauth-parent:1.0.0.BUILD-SNAPSHOT, /home/toddnine/development/spring-security-oauth/pom.xml, line 253, column 21
    [WARNING] 'reporting.plugins.plugin.version' for org.apache.maven.plugins:maven-jxr-plugin is missing. @ org.springframework.security.oauth:spring-security-oauth-parent:1.0.0.BUILD-SNAPSHOT, /home/toddnine/development/spring-security-oauth/pom.xml, line 288, column 21
    [WARNING] 
    [WARNING] It is highly recommended to fix these problems because they threaten the stability of your build.
    [WARNING] 
    [WARNING] For this reason, future Maven versions might no longer support building such malformed projects.
    [WARNING] 
    [INFO]                                                                         
    [INFO] ------------------------------------------------------------------------
    [INFO] Building OAuth2 for Spring Security 1.0.0.BUILD-SNAPSHOT
    [INFO] ------------------------------------------------------------------------
    [WARNING] The POM for com.springsource.bundlor:com.springsource.bundlor.maven:jar:1.0.0.RELEASE is missing, no dependency information available
    [INFO] ------------------------------------------------------------------------
    [INFO] BUILD FAILURE
    [INFO] ------------------------------------------------------------------------
    [INFO] Total time: 0.343s
    [INFO] Finished at: Tue Dec 20 12:15:22 NZDT 2011
    [INFO] Final Memory: 3M/119M
    [INFO] ------------------------------------------------------------------------
    [WARNING] The requested profile "bootstrap" could not be activated because it does not exist.
    [ERROR] Plugin com.springsource.bundlor:com.springsource.bundlor.maven:1.0.0.RELEASE or one of its dependencies could not be resolved: Failed to read artifact descriptor for com.springsource.bundlor:com.springsource.bundlor.maven:jar:1.0.0.RELEASE: Failure to find com.springsource.bundlor:com.springsource.bundlor.maven:pom:1.0.0.RELEASE in https://repo.spidertracks.com/artifactory/repo was cached in the local repository, resolution will not be reattempted until the update interval of repo has elapsed or updates are forced -> [Help 1]
    [ERROR] 
    [ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
    [ERROR] Re-run Maven using the -X switch to enable full debug logging.
    [ERROR] 
    [ERROR] For more information about the errors and possible solutions, please read the following articles:
    [ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/PluginResolutionException
    Any ideas how I can resolve this? I obviously need the bundlor plugin, but it's turned into finding a needle in a haystack. The pluginRepository in the pom matches the documentation here

    http://static.springsource.org/s2-bu...l/ch03s03.html

    except the plugin doesn't seem to be there....


    I'm happy to contribute the fix to the pom.xml and update the README.

    Thanks,
    Todd
    Last edited by tnine; Dec 19th, 2011, 05:23 PM.

  • #2
    I don't use Maven 3, and the build instructions clearly state that 2.2 is required, but I'm happy to accept a patch. You probably just need to add the SpringSource EBR repository to the plugin repositories. I think someone already did it with Spring Batch.

    Comment

    Working...
    X