Announcement Announcement Module
Collapse
No announcement yet.
problem when using maven repository Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • problem when using maven repository

    Hi all

    I'm having a tough time trying to use the maven repository of oauth.

    i've added this to my pom.xml
    Code:
    <dependency>
     <groupId>org.springframework.security.oauth</groupId>
     <artifactId>spring-security-oauth</artifactId>
     <version>1.0.0.M4</version>
    </dependency>
    but when netbeans tries to download the repo it allways gives me an error:

    Code:
    java.lang.AbstractMethodError
    	at org.sonatype.aether.connector.wagon.WagonRepositoryConnector.connectWagon(WagonRepositoryConnector.java:310)
    	at org.sonatype.aether.connector.wagon.WagonRepositoryConnector.pollWagon(WagonRepositoryConnector.java:378)
    	at org.sonatype.aether.connector.wagon.WagonRepositoryConnector$GetTask.run(WagonRepositoryConnector.java:578)
    	at org.sonatype.aether.util.concurrency.RunnableErrorForwarder$1.run(RunnableErrorForwarder.java:64)
    	at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
    	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
    [catch] at java.lang.Thread.run(Thread.java:680)
    hope someone can help
    kind regards

    UPDATE: it can't be the network/firewall. An other pc in the network doesn't have the problem and we tried to connect this pc to another wifi and it still doesn't work. :s
    Last edited by stece; Nov 28th, 2011, 05:02 AM.

  • #2
    We made an empty pom project and added the dependecies there. It started downloading without a problem and now our main project works. :s

    WEIRD!

    Comment

    Working...
    X