Announcement Announcement Module
Collapse
No announcement yet.
Spring Security OAuth 1.0.0.M5 released today Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Spring Security OAuth 1.0.0.M5 released today

    Spring Security OAuth 1.0.0.M5 was released today. Available from the usual S3 repository http://maven.springframework.org/milestone. Anyone who has been following progress will know that there are some quite significant changes since M4, so it's worth upgrading if you are on an older version. Highlights (all OAuth2):

    * New implementation of the Authorization Server endpoints
    * New XSD schema reflecting better the split in the spec between Authorization and Resource Server
    * Added support for implicit grant type
    * Added client side support for client credentials grant
    * A lot of refactoring to simplify names and interfaces and align more with the spec
    Last edited by Dave Syer; Nov 17th, 2011, 11:40 AM. Reason: tidying

  • #2
    Hi Dave,

    If I go to the link you mention (http://maven.springframework.org/milestone), I get a "No Items found". After cloning the repo from github and doing a "mvn install -P bootstrap", I get:

    Downloading: http://maven.springframework.org/rel...D-SNAPSHOT.pom
    [ERROR] The build could not read 4 projects -> [Help 1]
    [ERROR]
    [ERROR] The project org.springframework.security.oauth:sparklr:1.0.0.B UILD-SNAPSHOT (/Users/xxx/code/spring-security-oauth/samples/oauth/sparklr/pom.xml) has 1 error
    [ERROR] Non-resolvable parent POM: Could not find artifact org.springframework.security.oauth:spring-security-oauth-parentom:1.0.0.BUILD-SNAPSHOT in spring-milestone (http://maven.springframework.org/milestone) and 'parent.relativePath' points at wrong local POM @ line 5, column 10 -> [Help 2]

    Am I doing something wrong?

    Comment


    • #3
      If I then download the M5 (https://github.com/SpringSource/spri...pball/1.0.0.M5) and do "mvn install -P bootstrap", I get:

      [ERROR] Non-resolvable parent POM: Could not transfer artifact org.springframework.security.oauth:spring-security-oauth-parentom:1.0.0.M5 from/to spring-milestone (http://maven.springframework.org/milestone): Access denied to: http://maven.springframework.org/mil...t-1.0.0.M5.pom and 'parent.relativePath' points at wrong local POM @ line 5, column 10 -> [Help 2]

      Comment


      • #4
        It works for me starting with an empty local maven repo (with -DskipTests=true - I get a strange integration test failure otherwise, but not the dependency problem you see). The access denied error from your M5 build looks like an environment problem: do you have a network proxy or a repository mirror? You are running mvn from the root directory, right?

        Comment


        • #5
          Hi,
          which spring and spring security versions should be used with oauth version 1.0.0.M5.
          I am trying to use a jersey client with oauth security but i realized that oauth uses the method readProtectedResource to access a resource based on a URL, an access token and an HTTP method. how can i replace it by a jersey client?
          Thx

          Comment


          • #6
            which spring and spring security versions should be used with oauth version 1.0.0.M5.
            Look at the poms. Spring 3.0.6 and Spring Security 3.1 (M5 was released against RC3 I think).

            I don't really understand the Jersey question. You don't want to use Spring on the client at all? Or you want to use a Jersey client with the Spring client filters? I don't know which "readProtectedResource" you mean.

            Comment

            Working...
            X