Announcement Announcement Module
Collapse
No announcement yet.
newbie question Page Title Module
Move Remove Collapse
This topic is closed
X
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • newbie question

    Hi everyone!
    I am trying to integrate Acegi security into a web application using the Spring framework. The application runs fine initially. If I add a definition for the filterChainProxy in the Spring's applicationContext.xml, the application failed to be deployed properly, i. e., the application is no longer accessible with a Tomcat 404 status. Here is what i have tried to add in the xml file:

    <bean id="filterChainProxy" class="net.sf.acegisecurity.util.FilterChainProxy" >
    <property name="filterInvocationDefinitionSource">
    <value>
    CONVERT_URL_TO_LOWERCASE_BEFORE_COMPARISON
    PATTERN_TYPE_APACHE_ANT
    </value>
    </property>
    </bean>

    Pls corret me if I'm wrong, I think this piece of code does not depend on any other beans. I am trying to add it just to know if a simple Acegi bean definition would not cause errors. Unfortunately, it does. Can anyone help me out with this problem? Thanks in advance!
    By the way, I have the Acegi 0.8.3

    Ann

  • #2
    What is the content of the 404? Tomcat isn't able to find some file. Knowing what that is should help considerably.

    Comment


    • #3
      Tomcat reports that the requested resource, which is the web application, is not accessible. If i try to remove the Acegi bean definition, it is accessible. Is there something i'm missing here? Please help.

      Comment


      • #4
        My guess would be that there was some problem initializing your webapp's context and that it never deployed. Check the log files.

        Comment


        • #5
          i've checked the log file, the application is deployed properly. i wonder why a simple bean definition makes it inaccessible. :?

          Comment


          • #6
            pls disregard my previous post. yes, i think, there was a problem in deploying the application. This is what appears in the tomcat log file:

            Sep 8, 2005 1:37:46 PM org.apache.catalina.core.StandardContext start
            SEVERE: Error listenerStart
            Sep 8, 2005 1:37:46 PM org.apache.catalina.core.StandardContext start
            SEVERE: Context startup failed due to previous errors

            Comment

            Working...
            X