Announcement Announcement Module
Collapse
No announcement yet.
Git doesn't appear to be working.... Page Title Module
Move Remove Collapse
This topic is closed
X
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Git doesn't appear to be working....

    I'm trying to debug a problem, so I went to download the source for spring-security. git is just timing out. I've tried it with an unrelated project (mvpmc) and it worked.

    git clone git://git.springsource.org/spring-security/spring-security.git
    Initialized empty Git repository in /tmp/spring-security/spring-security/.git/
    fatal: read error (Connection reset by peer)

    I also tried with a different spring project and it also failed

    git clone git://git.springsource.org/dm-server/dm-server.git
    Initialized empty Git repository in /tmp/dm-server/.git/
    fatal: read error (Connection reset by peer)

  • #2
    git

    Its doing the same for me as well.

    Comment


    • #3
      Thanks for the heads-up. I 've pinged sysadmin and it should be back up now.

      Source jars are also part of the distro and are uploaded to Maven central so can be added to your IDE if you just need the code for debugging.

      Comment


      • #4
        Git down again?

        Is git down? I tried checking out spring-security and got a timed out. I am able to clone github without a problem though. Anyone else have this issue?

        Code:
        rwinch@rwinch:/tmp$ git clone git://git.springsource.org/spring-security/spring-security.git
        Initialized empty Git repository in /tmp/spring-security/.git/
        git.springsource.org[0: 89.21.231.40]: errno=Connection timed out
        fatal: unable to connect a socket (Connection timed out)
        
        rwinch@rwinch:/tmp$ git clone git://github.com/jquery/jquery.git
        Initialized empty Git repository in /tmp/jquery/.git/
        remote: Counting objects: 12608, done.
        remote: Compressing objects: 100% (3780/3780), done.
        remote: Total 12608 (delta 8588), reused 12280 (delta 8312)
        Receiving objects: 100% (12608/12608), 8.93 MiB | 1203 KiB/s, done.
        Resolving deltas: 100% (8588/8588), done.

        Comment


        • #5
          Still not working...

          I've been trying to clone the git repository yesterday and got the same error. Tried again today with no luck. Github repositories can be cloned and updated without problems so the problem should not be with my git installation.

          Is there a Subversion mirror or is the Git repository available elsewhere (only need read access)?

          Comment


          • #6
            Seems to be working for me at the moment

            Comment

            Working...
            X