Announcement Announcement Module
Collapse
No announcement yet.
cannot import "spring-security-2.0.4.xsd" while running with proxy Page Title Module
Move Remove Collapse
This topic is closed
X
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • cannot import "spring-security-2.0.4.xsd" while running with proxy

    Hi,

    When I run Jboss server at work I get some errors. After searching I've located the error its because of the internet proxy settings corresponding xsd file is not importing from net directly while running application. I've run the Jboss server locally at home (no proxy)and found that this indeed was the problem and spring-security-2.0.4.xsd is downloading directly ..

    How do I make Jboss use my http proxy?

    I am using Myeclipse 6.6
    Thanks

  • #2
    The file should be in the spring security jar, and is used from there. It shouldn't be downloaded.

    Comment


    • #3
      thanks for the reply sir ,but without proxy when internet is directly connected to ISP i am able to run the application ..but when i use proxy i am not able to run the application then i understood that some xsd files are directly imported when i use no proxy and application runs without exceptions
      can u please provide me jar which contains "spring-security-2.0.4.xsd" file

      Comment


      • #4
        I just spent this afternoon on this issue, so this might help someone else:

        I had the same issue while running GWT in hosted mode on a Jetty webserver.

        You should be 100% sure that your webserver has the spring-security-core-x.y.z.jar on its classpath.

        Then put a breakpoint in PluggableSchemaResolver.getSchemaMapping, that's the place where it resolves XSD schemas from the webserver classpath JARs using META-INF/spring.schemas files.

        META-INF/spring.schemas are contained in either spring-x.y.z.jar and spring-security-core-x.y.z.jar

        Fred

        Comment

        Working...
        X