Announcement Announcement Module
Collapse
No announcement yet.
Problem in Acegi Sample/add.jsp Page Title Module
Move Remove Collapse
This topic is closed
X
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problem in Acegi Sample/add.jsp

    Hello,
    i have a li problem.

    When I want to add an user in the Sample App and click on the add-link, I get this error:

    javax.servlet.ServletException: Unable to compile class for JSP

    An error occurred at line: 10 in the jsp file: /WEB-INF/jsp/add.jsp
    Generated servlet error:
    org.springframework.web.servlet.tags.BindStatus cannot be resolved or is not a type

    Please, who know's what's the problem here is..
    Thx, with best regards,
    Martin

  • #2
    I found the Problem but I donīt know how to fix it.

    The add.jsp work with JBoss 3.x, but it doesnīt work with JBoss 4.0.2.

    Can anybody help me? How can I use the sample app on JBoss 4?

    Thx, with best regards,
    Martin

    Comment


    • #3
      Are you deploying the app with the jar files in the WEB-INF/lib? It's something to do with the container not being able to find the Spring class when it tries to run javac on the compiled JSP file. You might want to try clearing out the tomcat work directories and any other temp files and see if that helps.

      Comment


      • #4
        Also check you don't have any Spring JARs in your server classloader, as it's a common gotcha.

        Comment


        • #5
          For reference:

          http://opensource.atlassian.com/proj.../browse/SEC-44

          There appears to be a problem with the spring.tld file in the sample app being out of date. You can remove it altogether - I think more recent containers should be able to locate the one in the spring jar file.

          Comment

          Working...
          X