Announcement Announcement Module
Collapse
No announcement yet.
RememberMe filter not working (tomcat 6.0.20 within Eclipse) Page Title Module
Move Remove Collapse
This topic is closed
X
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • RememberMe filter not working (tomcat 6.0.20 within Eclipse)

    Hi,
    I can see the cookie being set but the rememberme is not working as expected. Everytime i check the remember me checkbox and login, I close my browser window and then again go to the login (home) page, it just shows the empty login form again.

    Following is my config :
    HTML Code:
    <bean id="filterChainProxy" class="org.acegisecurity.util.FilterChainProxy">
    		<property name="filterInvocationDefinitionSource">
    			<value>
    				CONVERT_URL_TO_LOWERCASE_BEFORE_COMPARISON
    				PATTERN_TYPE_APACHE_ANT
    				/**=httpSessionContextIntegrationFilter, authenticationProcessingFilter, rememberMeProcessingFilter, exceptionTranslationFilter, filterInvocationInterceptor 
    			</value>
    		</property>
    </bean>
    
    <bean id="httpSessionContextIntegrationFilter" class="org.acegisecurity.context.HttpSessionContextIntegrationFilter" />
    
    <bean id="authenticationProcessingFilter" class="org.acegisecurity.ui.webapp.AuthenticationProcessingFilter">
    		<property name="authenticationManager" 	ref="authenticationManager"/>
    		<property name="filterProcessesUrl" 	value="/j_acegi_security_check" />
    		<property name="defaultTargetUrl" value="/postlogin.htm" />
    		<property name="authenticationFailureUrl" value="/home.htm?login_error=1" />
    		<property name="rememberMeServices" ref="rememberMeServices"/>
    </bean>
    
    
    
    <bean id="rememberMeProcessingFilter" class="org.acegisecurity.ui.rememberme.RememberMeProcessingFilter"> 
    	<property name="rememberMeServices" ref="rememberMeServices" />
    	<property name="authenticationManager" ref="authenticationManager" />
    </bean>
    
    <bean id="rememberMeServices" class="org.acegisecurity.ui.rememberme.TokenBasedRememberMeServices">
    	<property name="userDetailsService" ref="authenticationDao"/>
    	<property name="key" value="someTokenName"/>
    </bean>
    
    <bean id="rememberMeAuthenticationProvider" class="org.acegisecurity.providers.rememberme.RememberMeAuthenticationProvider">
    	<property name="key" value="someTokenName"/>
    </bean>
    Any pointers or debugging help would be appreciated.

    Thanks.
    Last edited by rabbit; Oct 6th, 2009, 02:27 AM. Reason: Incomplete data

  • #2
    anybody? even teeny weeny tips might help

    Comment

    Working...
    X