Announcement Announcement Module
Collapse
No announcement yet.
LDAP bind problem Page Title Module
Move Remove Collapse
This topic is closed
X
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • LDAP bind problem

    Hello,

    I am trying to use the ldap authentication feature with the configuration below.

    When I try to login, I observe that the system can look up the username and find the dn of the supplied user name successfully, but it doesn't try to bind with this dn using the supplied password.

    After searching the dn, the system bind again with the manager-dn and searches the groups of the user.

    As a result, I always get "bad credentials" error.

    Can you please advise where to look, what to study.

    I use tomcat 6 + struts 2 .

    Here is my cofiguration:

    <http>
    <intercept-url pattern="/login**" filters="none" />
    <intercept-url pattern="/**" access="ROLE_USER" />
    <form-login login-page="/login" default-target-url="/main" always-use-default-target="true" authentication-failure-url="/login?loginFailed=1" />
    </http>

    <authentication-provider>
    <ldap-user-service
    server-ref="ldapServer"
    user-search-base="OU=TR"
    user-search-filter="sAMAccountName={0}"
    group-search-base="OU=TR"
    group-search-filter="member={0}"
    role-prefix="ROLE_"
    />
    </authentication-provider>

    <ldap-server
    id="ldapServer"
    url="ldap://EUDC2:389/DC=eu,DC=com"
    manager-dn= "CN=admin,OU=Admins,OU=TR,DC=eu,DC=com"
    manager-password="123"
    />
Working...
X