Announcement Announcement Module
Collapse
No announcement yet.
Acegi works under JBoss, but not Websphere??? Page Title Module
Move Remove Collapse
This topic is closed
X
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • #31
    Problem with Rad not entering web site

    Error from previous posting was another app error just loading petclinic the following is from the console: (Condensed to fit posting limit)
    3:16:384 CDT] 00000014 ApplicationMg A WSVR0200I: Starting application: petclinicEAR
    [7/18/06 10:13:16:837 CDT] 00000017 WebContainer A SRVE0162I: Servlet Specification Level: 2.4
    [7/18/06 10:13:16:837 CDT] 00000017 WebContainer A SRVE0163I: Supported JSP Specification Level: 2.0
    [7/18/06 10:13:18:712 CDT] 00000014 WebGroup A SRVE0169I: Loading Web Module: Spring PetClinic.
    [7/18/06 10:13:19:462 CDT] 00000014 ContextLoader I Root WebApplicationContext: initialization started
    [7/18/06 10:13:19:462 CDT] 00000014 WebApp A SRVE0180I: [Spring PetClinic] [/petclinic] [Servlet.LOG]: Loading Spring root WebApplicationContext
    [7/18/06 10:13:19:853 CDT] 00000014 XmlBeanDefini I Loading XML bean definitions from ServletContext resource [/WEB-INF/applicationContext-jdbc.xml]
    [7/18/06 10:13:20:196 CDT] 00000014 XmlBeanDefini I Loading XML bean definitions from ServletContext resource [/WEB-INF/applicationContext-acegi-security.xml]
    [7/18/06 10:13:20:556 CDT] 00000014 XmlWebApplica I Bean factory for application context [Root WebApplicationContext]: org.springframework.beans.factory.support.DefaultL istableBeanFactory defining beans [propertyConfigurer,dataSource,transactionManager,h sqlClinic,mysqlClinic,clinic,methodSecurityInterce ptor,callMonitor,jmxExporter,filterChainProxy,http SessionContextIntegrationFilter,logoutFilter,authe nticationProcessingFilter,securityContextHolderAwa reRequestFilter,rememberMeProcessingFilter,anonymo usProcessingFilter,exceptionTranslationFilter,filt erInvocationInterceptor,rememberMeServices,authent icationManager,daoAuthenticationProvider,userDetai lsService,loggerListener]; root of BeanFactory hierarchy
    [org.springframework.beans.factory.support.DefaultL istableBeanFactory defining beans [propertyConfigurer,dataSource,transactionManager,h sqlClinic,mysqlClinic,clinic,methodSecurityInterce ptor,callMonitor,jmxExporter,filterChainProxy,http SessionContextIntegrationFilter,logoutFilter,authe nticationProcessingFilter,securityContextHolderAwa reRequestFilter,rememberMeProcessingFilter,anonymo usProcessingFilter,exceptionTranslationFilter,filt erInvocationInterceptor,rememberMeServices,authent icationManager,daoAuthenticationProvider,userDetai lsService,loggerListener]; root of BeanFactory hierarchy]
    [7/18/06 10:13:21:118 CDT] 00000014 DefaultAopPro I CGLIB2 available: proxyTargetClass feature enabled
    [7/18/06 10:13:21:540 CDT] 00000014 PropertiesFac I Loading properties file from ServletContext resource [/WEB-INF/users.properties]
    [7/18/06 10:13:21:571 CDT] 00000014 UserMap I Adding user [org.acegisecurity.userdetails.User@bc4300: Username: marissa; Password: [PROTECTED]; Enabled: true; AccountNonExpired: true; credentialsNonExpired: true; AccountNonLocked: true; Granted Authorities: ROLE_SUPERVISOR]
    [7/18/06 10:13:21:618 CDT] 00000014 EhCacheManage I Initializing EHCache CacheManager
    [7/18/06 10:13:21:650 CDT] 00000014 Configurator W No configuration found. Configuring ehcache from ehcache-failsafe.xml found in the classpath: wsjar:file:/C:/Downloads/Frameworks/spring-framework-1.2.8/samples/petclinic/WebContent/WEB-INF/lib/ehcache-1.1.jar!/ehcache-failsafe.xml
    [7/18/06 10:13:21:696 CDT] 00000014 EhCacheFactor I Creating new EHCache cache region 'userCache'
    [7/18/06 10:13:21:821 CDT] 00000014 MethodDefinit I Adding secure method [public abstract void org.springframework.samples.petclinic.Clinic.store Visit(org.springframework.samples.petclinic.Visit) throws org.springframework.dao.DataAccessException] with attributes [[ROLE_SUPERVISOR]]
    [7/18/06 10:13:21:821 CDT] 00000014 MethodDefinit I Adding secure method [public abstract java.util.Collection org.springframework.samples.petclinic.Clinic.getVe ts() throws org.springframework.dao.DataAccessException] with attributes [[IS_AUTHENTICATED_REMEMBERED]]
    [7/18/06 10:13:21:868 CDT] 00000014 MethodDefinit I Adding secure method [public abstract java.util.Collection org.springframework.samples.petclinic.Clinic.getPe tTypes() throws org.springframework.dao.DataAccessException] with attributes [[IS_AUTHENTICATED_REMEMBERED]]
    [7/18/06 10:13:21:868 CDT] 00000014 MethodDefinit I Adding secure method [public abstract java.util.Collection org.springframework.samples.petclinic.Clinic.findO wners(java.lang.String) throws org.springframework.dao.DataAccessException] with attributes [[IS_AUTHENTICATED_REMEMBERED]]
    [7/18/06 10:13:21:868 CDT] 00000014 MethodDefinit I Adding secure method [public abstract org.springframework.samples.petclinic.Owner org.springframework.samples.petclinic.Clinic.loadO wner(int) throws org.springframework.dao.DataAccessException] with attributes [[IS_AUTHENTICATED_REMEMBERED]]
    [7/18/06 10:13:21:868 CDT] 00000014 MethodDefinit I Adding secure method [public abstract org.springframework.samples.petclinic.Pet org.springframework.samples.petclinic.Clinic.loadP et(int) throws org.springframework.dao.DataAccessException] with attributes [[IS_AUTHENTICATED_REMEMBERED]]
    [7/18/06 10:13:21:900 CDT] 00000014 MethodDefinit I Adding secure method [public abstract void org.springframework.samples.petclinic.Clinic.store Owner(org.springframework.samples.petclinic.Owner) throws org.springframework.dao.DataAccessException] with attributes [[IS_AUTHENTICATED_REMEMBERED]]
    [7/18/06 10:13:21:900 CDT] 00000014 MethodDefinit I Adding secure method [public abstract void org.springframework.samples.petclinic.Clinic.store Pet(org.springframework.samples.petclinic.Pet) throws org.springframework.dao.DataAccessException] with attributes [[IS_AUTHENTICATED_REMEMBERED]]
    [7/18/06 10:13:22:431 CDT] 00000014 ContextLoader I Using context class [org.springframework.web.context.support.XmlWebAppl icationContext] for root WebApplicationContext
    [7/18/06 10:13:22:431 CDT] 00000014 ContextLoader I Root WebApplicationContext: initialization completed in 2969 ms
    [7/18/06 10:13:22:478 CDT] 00000014 DispatcherSer I Initializing servlet 'petclinic'
    [7/18/06 10:13:22:540 CDT] 00000014 DispatcherSer I FrameworkServlet 'petclinic': initialization started
    [7/18/06 10:13:22:540 CDT] 00000014 WebApp A SRVE0180I: [Spring PetClinic] [/petclinic] [Servlet.LOG]: Loading WebApplicationContext for Spring FrameworkServlet 'petclinic'
    org.springframework.beans.factory.support.DefaultL istableBeanFactory defining beans [propertyConfigurer,dataSource,transactionManager,h sqlClinic,mysqlClinic,clinic,methodSecurityInterce ptor,callMonitor,jmxExporter,filterChainProxy,http SessionContextIntegrationFilter,logoutFilter,authe nticationProcessingFilter,securityContextHolderAwa reRequestFilter,rememberMeProcessingFilter,anonymo usProcessingFilter,exceptionTranslationFilter,filt erInvocationInterceptor,rememberMeServices,authent icationManager,daoAuthenticationProvider,userDetai lsService,loggerListener]; root of BeanFactory hierarchy
    [7/18/06 10:13:22:853 CDT] 00000014 XmlWebApplica I 15 beans defined in application context [WebApplicationContext for namespace 'petclinic-servlet']
    [org.springframework.beans.factory.support.DefaultL istableBeanFactory defining beans [messageSource,viewResolver,exceptionResolver,urlMa pping,clinicController,clinicControllerResolver,fi ndOwnersForm,addOwnerForm,editOwnerForm,ownerValid ator,addPetForm,editPetForm,petValidator,addVisitF orm,visitValidator]; parent: org.springframework.beans.factory.support.DefaultL istableBeanFactory defining beans [propertyConfigurer,dataSource,transactionManager,h sqlClinic,mysqlClinic,clinic,methodSecurityInterce ptor,callMonitor,jmxExporter,filterChainProxy,http SessionContextIntegrationFilter,logoutFilter,authe nticationProcessingFilter,securityContextHolderAwa reRequestFilter,rememberMeProcessingFilter,anonymo usProcessingFilter,exceptionTranslationFilter,filt erInvocationInterceptor,rememberMeServices,authent icationManager,daoAuthenticationProvider,userDetai lsService,loggerListener]; root of BeanFactory hierarchy]
    [7/18/06 10:13:23:462 CDT] 00000014 DispatcherSer I Using context class [org.springframework.web.context.support.XmlWebAppl icationContext] for servlet 'petclinic'
    [7/18/06 10:13:23:462 CDT] 00000014 DispatcherSer I Unable to locate LocaleResolver with name 'localeResolver': using default [org.springframework.web.servlet.i18n.AcceptHeaderL ocaleResolver@2b1b8d8]
    [7/18/06 10:13:23:478 CDT] 00000014 DispatcherSer I Unable to locate ThemeResolver with name 'themeResolver': using default [7/18/06 10:13:23:525 CDT] 00000014 DispatcherSer I FrameworkServlet 'petclinic': initialization completed in 985 ms
    [7/18/06 10:13:23:525 CDT] 00000014 DispatcherSer I Servlet 'petclinic' configured successfully
    [7/18/06 10:13:23:525 CDT] 00000014 ServletWrappe A SRVE0242I: [petclinic]: Initialization successful.
    [7/18/06 10:13:25:946 CDT] 00000018 ServletWrappe A SRVE0242I: [action]: Initialization successful.
    [7/18/06 10:13:25:993 CDT] 00000018 ServletWrappe A SRVE0242I: [SecureCleanup]: Initialization successful.
    [7/18/06 10:14:23:103 CDT] 00000039 LoggerListene W Authentication event AuthenticationSuccessEvent: marissa; details: org.acegisecurity.ui.WebAuthenticationDetails@fffe d504: RemoteIpAddress: 127.0.0.1; SessionId: fHvOQM9q8rbX5Z_b1pnWsnX
    [7/18/06 10:14:23:150 CDT] 00000039 LoggerListene W Authentication event InteractiveAuthenticationSuccessEvent: marissa; details: org.acegisecurity.ui.WebAuthenticationDetails@fffe d504: RemoteIpAddress: 127.0.0.1; SessionId: fHvOQM9q8rbX5Z_b1pnWsnX

    Looks to me like user is authenticated but it never goes on to the next page? As I described earlier it works fine in Tomcat 5.0.

    Comment


    • #32
      It doesn't look like you have debug logging on. Could you try it again with debugging enabled?

      Comment


      • #33
        Problem with Rad not entering web site

        Unfortunately since I was new to using Acegi I thought it was causing the problem but it turned out to be a rad issue of not clearing out previous deployments properly. It was not deleting old pointers to previous versions and was hanging on trying to deloy app with the same name under directory \IBM\Rational\SDP\6.0\runtimes\base_v6\profiles\de fault. After searching through rads server sub directory I found these and manually deleted them then restarted workspace and deployed, app came up correctly and security worked properly.
        Thanks for responses I hope anyone else working in Rad maybe helped by this post.

        Comment

        Working...
        X