Announcement Announcement Module
Collapse
No announcement yet.
j_acegi_cas_security_check 404 Page Title Module
Move Remove Collapse
This topic is closed
X
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • j_acegi_cas_security_check 404

    I have been running my CAS secured app on a local copy of Websphere 6, with CAS running on Tomcat. This all works fine.

    I have now deployed to a Websphere cluster (2 servers) fronted by another server running IBM Http Server (aka APACHE).

    I type in the URL of my app:

    http://httpserveripaddress/App/index.html

    it is redirected to a CAS signon screen and I log on.

    CAS then redirects back to the web server fronting the two nodes in the cluster:

    http://httpserveripaddress/App/_aceg...byWhHQc70HW-20

    At this point I get a Error 404: SRVE0190E: File not found: /j_acegi_cas_security_check

    bear in mind the actual app will be running on a websphere node behind the web server, and the web server should forward the request to a node in its cluster. It looks like the web server isn't even forwarding this on to a websphere node, though it obviously is when I request my original URL that is protected by CAS.

    Any ideas ?

  • #2
    Originally posted by Paul Newport View Post
    At this point I get a Error 404: SRVE0190E: File not found: /j_acegi_cas_security_check

    Just in case anyone else gets this, it's caused by a bug in Websphere, for which there is a fix. The clue is that SRVE0190E is a Websphere error message not a web server error.

    See here:

    http://forum.springframework.org/sho...scompatibility

    Comment

    Working...
    X