Announcement Announcement Module
Collapse
No announcement yet.
Upgrading from 1.0.0 RC2 to 1.0.0 Final - FilterChainProxy Page Title Module
Move Remove Collapse
This topic is closed
X
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Upgrading from 1.0.0 RC2 to 1.0.0 Final - FilterChainProxy

    I'm trying to upgrade from 1.0.0 RC2 to 1.0.0 Final (Spring 1.2.8) and I'm getting the following error:

    ===================
    org.springframework.beans.factory.BeanCreationExce ption: Error creating bean with name 'filterChainProxy' defined in ServletContext resource [/WEB-INF/acegi-base.xml]: Initialization of bean failed; nested exception is java.lang.NoSuchMethodError: org.apache.commons.lang.StringUtils.substringBefor eLast(Ljava/lang/String;Ljava/lang/StringLjava/lang/String;
    java.lang.NoSuchMethodError: org.apache.commons.lang.StringUtils.substringBefor eLast(Ljava/lang/String;Ljava/lang/StringLjava/lang/String;
    at org.acegisecurity.intercept.web.FilterInvocationDe finitionSourceEditor.setAsText(FilterInvocationDef initionSourceEditor.java:132)
    at org.springframework.beans.BeanWrapperImpl.doTypeCo nversionIfNecessary(BeanWrapperImpl.java:881)
    at org.springframework.beans.BeanWrapperImpl.setPrope rtyValue
    ===================

    Nothing has changed in my acegi configuration:

    <bean id="filterChainProxy" class="org.acegisecurity.util.FilterChainProxy">
    <property name="filterInvocationDefinitionSource">
    <value>
    CONVERT_URL_TO_LOWERCASE_BEFORE_COMPARISON
    PATTERN_TYPE_APACHE_ANT
    /**=httpSessionContextIntegrationFilter,authenticat ionProcessingFilter,exceptionTranslationFilter,fil terInvocationInterceptor
    </value>
    </property>
    </bean>

    Anyone have any ideas?

    Thanks.
    hbm

  • #2
    Nevermind... upgrading to commons-lang 2.1 fixed the problem.

    Comment

    Working...
    X