Announcement Announcement Module
Collapse
No announcement yet.
Acegi 1.0 causes additional logging from XDoclet and Canoo WebTest Page Title Module
Move Remove Collapse
This topic is closed
X
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Acegi 1.0 causes additional logging from XDoclet and Canoo WebTest

    For some reason, upgrading from 1.0.0-RC2 to 1.0.0 causes additional logging in my application. I cracked open the RC2 JAR and compared it with the 1.0.0 JAR. It looks like RC2 had a log4j.properties in its root classpath. However, the rules in this file only affect Acegi. With 1.0.0, I'm seeing additional logging from XDoclet and Canoo WebTest.

    With RC2:

    Code:
    (xdoclet)
    webdoclet:
    [webdoclet] Generating appfuse.tld.
    
    ...
    
    (webtest)
    Login:
    
    Logout:
    With 1.0.0:

    Code:
    (xdoclet)
    webdoclet:
    [webdoclet] (XDocletMain.start                   48  ) Running <jsptaglib/>
    [webdoclet] Generating appfuse.tld.
    [webdoclet] (XDocletMain.start                   48  ) Running <strutsconfigxml/>
    [webdoclet] (TemplateSubTask.engineStarted       829 ) Generating output 'struts-config.xml' using template file 'jar:file:/Users/mraible/Work/appfuse/lib/xdoclet-1.3-SNAPSHOT/xdoclet-apache-module-1.3-SNAPSHOT.jar!/xdoclet/modules/apache/struts/resources/struts_config_xml.xdt'.
    [webdoclet] (XDocletMain.start                   48  ) Running <strutsvalidationxml/>
    [webdoclet] (TemplateSubTask.engineStarted       829 ) Generating output 'validation.xml' using template file 'jar:file:/Users/mraible/Work/appfuse/lib/xdoclet-1.3-SNAPSHOT/xdoclet-apache-module-1.3-SNAPSHOT.jar!/xdoclet/modules/apache/struts/resources/validation_xml.xdt'.
    
    ...
    
    (webtest)
    Login:
    [clickbutton] [appfuse] INFO [main] Document.jsxSet_cookie(388) | Added cookie: username=mraible
    
    Logout:
    [clickbutton] [appfuse] INFO [main] Document.jsxSet_cookie(388) | Added cookie: username=mraible
    Maybe this is "as designed" and things where actually broken before?

  • #2
    This is not an Acegi issue - except that RC2 had a log4j.properties in its root directory. So that version was messed up, but 1.0.0 doesn't have it - hence the additional logging. I've turned down the logging in my own log4j.properties file.

    Thanks,

    Matt

    Comment

    Working...
    X