Announcement Announcement Module
Collapse
No announcement yet.
When will there be a release compatible with framework 3.2.x? Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • When will there be a release compatible with framework 3.2.x?

    I'm trying to consume Spring Security with Spring Framework 3.2.1 (or 3.2.2) but there's no version compatible. When will there be a release of security compatible with latest framework?

    Craig

  • #2
    Hi CraigFoote,

    I'm adding Spring Security in my application. In this link has It requires a minimum of Spring 3.0.6 . Why is not compatible?
    I'm asking because I'm having some errors, like this:

    PWC1270: Exception starting filter springSecurityFilterChain

    My web.xml

    <context-param>
    <param-name>contextConfigLocation</param-name>
    <param-value>
    /WEB-INF/classes/applicationContext.xml
    </param-value>
    </context-param>

    <listener>
    <listener-class>
    org.springframework.web.context.ContextLoaderListe ner
    </listener-class>
    </listener>

    <!-- Configurações do SpringSecurity -->
    <filter>
    <filter-name>springSecurityFilterChain</filter-name>
    <filter-class>org.springframework.web.filter.DelegatingFil terProxy</filter-class>
    </filter>




    <filter-mapping>
    <filter-name>springSecurityFilterChain</filter-name>
    <url-pattern>/*</url-pattern>
    </filter-mapping>

    Comment


    • #3
      I'm using the OSGi bundles which are limited to Spring Framework 3.1.x. I've been told a new version of Spring Security compatible with 3.2.x will be released around July.

      Craig

      Comment

      Working...
      X