Announcement Announcement Module
No announcement yet. E dependency Page Title Module
Move Remove Collapse
Conversation Detail Module
  • Filter
  • Time
  • Show
Clear All
new posts

  • E dependency

    We're migrating our code to use SpringFramework-3.2.1 and have come across a problem. We have a dependency on, the latest of which is 3.1.3.RELEASE but it has an Import-Package on org.springframework.remoting.httpinvoker;version="[3.0.7.RELEASE, 3.2.0)" and so is not compatible with org.springframework.web_3.2.1.RELEASE.

    We found this resolved Jira ticket:

    ... which details three other artifacts with the same problem. Patched jars were made available for them. Is there a later release of available without this limitation?

    Craig Foote
    Last edited by CraigFoote; Apr 15th, 2013, 12:07 PM.

  • #2
    The JIRA is resolved, but not closed. This means it has been fixed, but the code has not yet been released with the fix. The patch submitted should resolve the problem for the remoting bundle as well. You can verify this by cloning the code and performing a build. If you are really eager for the OSGi changes, you can build the 3.1.x branch and build it yourself.