Announcement Announcement Module
Collapse
No announcement yet.
Spring Security 3.1.x Comptability with Spring 3.2? Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Spring Security 3.1.x Comptability with Spring 3.2?

    I want to upgrade my app form Spring Framework 3.1.4 to 3.2.1 but I am using Spring Security 3.1.3 heavily and want to make sure that the upgrade is safe to do.

    Does the Spring Security Team endorse a Spring Security 3.1.x + Spring framework 3.2 combination or should I wait till Spring Security 3.2 is officially out.

  • #2
    Spring Security should work with Spring 3.2 (which is a passive release).

    Comment


    • #3
      I build a Project with Spring Framework 3.2.1 and Spring Security 3.1.3 and had much problems.
      I read that since Spring Framework 3.2.0 the asm is integrated in the package.

      But after I removed the asm from the security package it worked.
      A real convenient method with Maven

      Code:
              <dependency>
                  <groupId>org.springframework.security</groupId>
                  <artifactId>spring-security-config</artifactId>
                  <version>3.1.3.RELEASE</version>
                  <exclusions>
                      <exclusion>
                          <artifactId>spring-asm</artifactId>
                          <groupId>org.springframework</groupId>
                      </exclusion>
                  </exclusions>
              </dependency>
      Perhaps can someone told me, if this is a good solution or can this have disadvantages what yet is not to observe.

      Comment

      Working...
      X